# CVE-2025-27152: Possible SSRF and Credential Leakage via Absolute URL in axios Requests

> Attackers can trigger Server-Side Request Forgery and leak credentials by passing absolute URLs to the axios HTTP client library.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2025
- **Updated:** 7 Mar 2025
- **Also known as:** DEBIAN-CVE-2025-27152, ECHO-c986-b553-eb7a, GHSA-jr5f-v2jv-69x6, MINI-7jc4-32fg-h2xr, MINI-c73m-45h9-xgcj, ROOT-APP-NPM-CVE-2025-27152, SUSE-SU-2025:1227-1, UBUNTU-CVE-2025-27152

## What is CVE-2025-27152?

CVE-2025-27152 is a high-severity server-side request forgery vulnerability in axios, published on 7 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

axios is a promise based HTTP client for the browser and node.js. The issue occurs when passing absolute URLs rather than protocol-relative URLs to axios. Even if ⁠baseURL is set, axios sends the request to the specified absolute URL, potentially causing SSRF and credential leakage. This issue impacts both server-side and client-side usage of axios. This issue is fixed in 1.8.2.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-27152?

4 open source packages ship an affected version, including axios. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `axios` | npm | All versions | 0.30.0 |
| `axios` | npm | All versions | 0.30.0 |
| `axios` | npm | From 1.0.0 | 1.8.2 |
| `axios` | npm | From 1.0.0 | 1.8.2 |
| `pgadmin4` | SUSE:Linux Enterprise Module for Python 3 15 SP6 | All versions | 8.5-150600.3.9.1 |
| `pgadmin4` | openSUSE:Leap 15.6 | All versions | 8.5-150600.3.9.1 |

Products: Axios Axios.

## How do I fix CVE-2025-27152?

Upgrade axios to a fixed version for your release line: 0.30.0 or 1.8.2.

## Is CVE-2025-27152 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27152 exists.

Public exploit code:

- Demonstration of CVE-2025-27152 (github_poc): https://github.com/andreglock/axios-ssrf
- Axios CVE-2025-27152 PoC (github_poc): https://github.com/davidblakecoe/axios-CVE-2025-27152-PoC

## Other vulnerabilities in axios

- [CVE-2026-44494](https://insights.sbomify.com/CVE-2026-44494/): Axios: Full Man-in-the-Middle via Prototype Pollution Gadget in `config.proxy` (high 8.7)
- [CVE-2026-44492](https://insights.sbomify.com/CVE-2026-44492/): axios's shouldBypassProxy does not recognize IPv4-mapped IPv6 addresses, allowing NO_PROXY bypass (incomplete fix for CVE-2025-62718) (high 8.6)
- [CVE-2026-67320](https://insights.sbomify.com/CVE-2026-67320/): axios before 0.33.0 Prototype Pollution via Node HTTP adapter (high 8.3)
- [CVE-2026-44487](https://insights.sbomify.com/CVE-2026-44487/): Axios: Proxy-Authorization Credential Leak to Origin Server Across HTTP-to-HTTPS Redirect in Axios Node.js HTTP Adapter (high 8.2)
- [CVE-2026-44486](https://insights.sbomify.com/CVE-2026-44486/): Axios: Proxy-Authorization header leaks to redirect target when proxy is re-evaluated to direct connection (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27152 and fix it if it is affected.

What it is: CVE-2025-27152 is a high-severity server-side request forgery vulnerability in axios, published on 7 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27152 exists.

Affected packages and fixed versions:
- axios (npm): affected all versions; fixed in 0.30.0
- axios (npm): affected all versions; fixed in 0.30.0
- axios (npm): affected from 1.0.0; fixed in 1.8.2
- axios (npm): affected from 1.0.0; fixed in 1.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27152/ (Markdown: https://insights.sbomify.com/CVE-2025-27152/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27152
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27152
- OSV: https://osv.dev/vulnerability/CVE-2025-27152

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27152/
Summaries are generated and may contain mistakes; the official description above is the record.
