{"answers":{"affected":"3 open source packages ship an affected version, including spotipy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-27154 in the wild and no public exploit code.","fix":"Upgrade spotipy to 2.25.1 or later.","what":"CVE-2025-27154 is a high-severity vulnerability in spotipy-dev spotipy, published on 27 Feb 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-27154 and fix it if it is affected.\n\nWhat it is: CVE-2025-27154 is a high-severity vulnerability in spotipy-dev spotipy, published on 27 Feb 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-27154 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- spotipy (PyPI): affected all versions; fixed in 2.25.1\n- spotipy (PyPI): affected all versions; fixed in 2.25.1\n- spotipy (PyPI): affected all versions; fixed in 2.25.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-27154/ (Markdown: https://insights.sbomify.com/CVE-2025-27154/index.md)","id":"CVE-2025-27154","markdown":"https://insights.sbomify.com/CVE-2025-27154/index.md","name":"CVE-2025-27154","record":{"aliases":["DEBIAN-CVE-2025-27154","GHSA-pwhh-q4h6-w599","PYSEC-2026-1936","UBUNTU-CVE-2025-27154","openSUSE-SU-2025:14847-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python Spotify API library","requires_auth":"low_privilege","summary":"Local attackers can read Spotify auth tokens from cache files with overly broad permissions, potentially leading to account takeover.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"spotipy","vendor":"spotipy_project"}],"cvss":{"score":8.4,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-276","name":"Incorrect Default Permissions"}],"description":"Spotipy is a lightweight Python library for the Spotify Web API. The `CacheHandler` class creates a cache file to store the auth token. Prior to version 2.25.1, the file created has `rw-r--r--` (644) permissions by default, when it could be locked down to `rw-------` (600) permissions. This leads to overly broad exposure of the spotify auth token. If this token can be read by an attacker (another user on the machine, or a process running as another user), it can be used to perform administrative actions on the Spotify account, depending on the scope granted to the token. Version 2.25.1 tightens the cache file permissions.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Spotipy's cache file, containing spotify auth token, is created with overly broad permissions","id":"CVE-2025-27154","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":4,"n_references":4,"next":{"headline":"In-memory stored Cross-site scripting (XSS) vulnerability in pineconesim","id":"CVE-2025-27155"},"packages":[{"ecosystem":"PyPI","fixed":["2.25.1"],"introduced":["0"],"last_affected":[],"package":"spotipy","purl":null,"source":"GHSA-pwhh-q4h6-w599"},{"ecosystem":"PyPI","fixed":["2.25.1"],"introduced":["0"],"last_affected":[],"package":"spotipy","purl":"pkg:pypi/spotipy","source":"GHSA-pwhh-q4h6-w599"},{"ecosystem":"PyPI","fixed":["2.25.1"],"introduced":["0"],"last_affected":[],"package":"spotipy","purl":"pkg:pypi/spotipy","source":"PYSEC-2026-1936"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.25.1-1.1"],"introduced":["0"],"last_affected":[],"package":"python-spotipy","purl":"pkg:rpm/opensuse/python-spotipy\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:14847-1"}],"prev":{"headline":"Escalade GLPI Plugin Vulnerable to Improper Access Control","id":"CVE-2025-27153"},"products":["spotipy"],"published":"2025-02-27","related":[{"cvss_score":0,"headline":"spotipy Path traversal vulnerability that may lead to type confusion in URI handling code","id":"CVE-2023-23608","kev_date_added":null,"published":"2023-01-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-27","vendors":["spotipy-dev"]},"summary":"Local attackers can read Spotify auth tokens from cache files with overly broad permissions, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2025-27154/"}