# CVE-2025-27154: Spotipy's cache file, containing spotify auth token, is created with overly broad permissions

> Local attackers can read Spotify auth tokens from cache files with overly broad permissions, potentially leading to account takeover.

- **Severity:** High 8.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Feb 2025
- **Updated:** 27 Feb 2025
- **Also known as:** DEBIAN-CVE-2025-27154, GHSA-pwhh-q4h6-w599, PYSEC-2026-1936, UBUNTU-CVE-2025-27154, openSUSE-SU-2025:14847-1

## What is CVE-2025-27154?

CVE-2025-27154 is a high-severity vulnerability in spotipy-dev spotipy, published on 27 Feb 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Spotipy is a lightweight Python library for the Spotify Web API. The `CacheHandler` class creates a cache file to store the auth token. Prior to version 2.25.1, the file created has `rw-r--r--` (644) permissions by default, when it could be locked down to `rw-------` (600) permissions. This leads to overly broad exposure of the spotify auth token. If this token can be read by an attacker (another user on the machine, or a process running as another user), it can be used to perform administrative actions on the Spotify account, depending on the scope granted to the token. Version 2.25.1 tightens the cache file permissions.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2025-27154?

3 open source packages ship an affected version, including spotipy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `spotipy` | PyPI | All versions | 2.25.1 |
| `spotipy` | PyPI | All versions | 2.25.1 |
| `spotipy` | PyPI | All versions | 2.25.1 |
| `python-spotipy` | openSUSE:Tumbleweed | All versions | 2.25.1-1.1 |

Products: Spotipy Project Spotipy.

## How do I fix CVE-2025-27154?

Upgrade spotipy to 2.25.1 or later.

## Is CVE-2025-27154 being exploited?

There is no known exploitation of CVE-2025-27154 in the wild and no public exploit code.

## Other vulnerabilities in spotipy-dev spotipy

- [CVE-2023-23608](https://insights.sbomify.com/CVE-2023-23608/): spotipy Path traversal vulnerability that may lead to type confusion in URI handling code (not scored)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27154 and fix it if it is affected.

What it is: CVE-2025-27154 is a high-severity vulnerability in spotipy-dev spotipy, published on 27 Feb 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27154 in the wild and no public exploit code.

Affected packages and fixed versions:
- spotipy (PyPI): affected all versions; fixed in 2.25.1
- spotipy (PyPI): affected all versions; fixed in 2.25.1
- spotipy (PyPI): affected all versions; fixed in 2.25.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27154/ (Markdown: https://insights.sbomify.com/CVE-2025-27154/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27154
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27154
- OSV: https://osv.dev/vulnerability/CVE-2025-27154

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27154/
Summaries are generated and may contain mistakes; the official description above is the record.
