{"answers":{"affected":"2 open source packages ship an affected version, including node and node-min.","exploited":"There is no known exploitation of CVE-2025-27209 in the wild and no public exploit code.","fix":"Upgrade node to 24.4.1 or later.","what":"CVE-2025-27209 is a high-severity denial of service vulnerability in nodejs node, published on 18 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-27209 and fix it if it is affected.\n\nWhat it is: CVE-2025-27209 is a high-severity denial of service vulnerability in nodejs node, published on 18 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-27209 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- node (Bitnami): affected from 24.0.0; fixed in 24.4.1\n- node-min (Bitnami): affected from 24.0.0; fixed in 24.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-27209/ (Markdown: https://insights.sbomify.com/CVE-2025-27209/index.md)","id":"CVE-2025-27209","markdown":"https://insights.sbomify.com/CVE-2025-27209/index.md","name":"CVE-2025-27209","record":{"aliases":["BIT-node-2025-27209","BIT-node-min-2025-27209","GHSA-qr33-gf7m-pq45","MINI-jw94-h8cm-5xr2"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js runtime","requires_auth":"none","summary":"Attackers can cause denial of service in Node.js v24 by exploiting hash collisions in the V8 engine's string hashing implementation.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-407","name":"Inefficient Algorithmic Complexity"}],"description":"The V8 release used in Node.js v24.0.0 has changed how string hashes are computed using rapidhash. This implementation re-introduces the HashDoS vulnerability as an attacker who can control the strings to be hashed can generate many hash collisions - an attacker can generate collisions even without knowing the hash-seed.\r\n\r\n* This vulnerability affects Node.js v24.x users.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in node","id":"CVE-2025-27209","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Path traversal in node","id":"CVE-2025-27210"},"packages":[{"ecosystem":"Bitnami","fixed":["24.4.1"],"introduced":["24.0.0"],"last_affected":[],"package":"node","purl":"pkg:bitnami/node","source":"BIT-node-2025-27209"},{"ecosystem":"Bitnami","fixed":["24.4.1"],"introduced":["24.0.0"],"last_affected":[],"package":"node-min","purl":"pkg:bitnami/node-min","source":"BIT-node-min-2025-27209"}],"prev":{"headline":"Cross-site scripting in Revive Adserver","id":"CVE-2025-27208"},"products":["node"],"published":"2025-07-18","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["nodejs"]},"summary":"Attackers can cause denial of service in Node.js v24 by exploiting hash collisions in the V8 engine's string hashing implementation.","url":"https://insights.sbomify.com/CVE-2025-27209/"}