{"answers":{"affected":"6 open source packages ship an affected version, including cgi. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-27219 in the wild and no public exploit code.","fix":"Upgrade cgi to a fixed version for your release line: 0.3.5.1, 0.3.7 or 0.4.2.","what":"CVE-2025-27219 is a medium-severity denial of service vulnerability in ruby-lang CGI, published on 3 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-27219 and fix it if it is affected.\n\nWhat it is: CVE-2025-27219 is a medium-severity denial of service vulnerability in ruby-lang CGI, published on 3 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-27219 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cgi (RubyGems): affected all versions; fixed in 0.3.5.1\n- cgi (RubyGems): affected all versions; fixed in 0.3.5.1\n- cgi (RubyGems): affected from 0.3.6; fixed in 0.3.7\n- cgi (RubyGems): affected from 0.3.6; fixed in 0.3.7\n- cgi (RubyGems): affected from 0.4.0; fixed in 0.4.2\n- cgi (RubyGems): affected from 0.4.0; fixed in 0.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-27219/ (Markdown: https://insights.sbomify.com/CVE-2025-27219/index.md)","id":"CVE-2025-27219","markdown":"https://insights.sbomify.com/CVE-2025-27219/index.md","name":"CVE-2025-27219","record":{"aliases":["ALPINE-CVE-2025-27219","AZL-57828","AZL-57923","CLEANSTART-2026-BY72007","CLEANSTART-2026-JU41543","DEBIAN-CVE-2025-27219","ECHO-66e4-e8d1-c7e8","GHSA-gh9q-2xrm-x6qv","MINI-39rw-4457-p7w3","MINI-5gxg-72f4-6jwp","MINI-74xg-j2pp-528j","MINI-8rf2-q5jm-5h55","MINI-95rv-j253-f8mg","MINI-c3jm-49p9-5m72","MINI-f8r8-846q-v9p9","MINI-gcvh-xjcv-w237","MINI-jpfc-wfmm-5w9j","MINI-p94m-62w2-jpfp","MINI-pwmx-3r6c-9m64","MINI-wc4p-57pq-43p9","MINI-xff6-mfj2-mh8h","UBUNTU-CVE-2025-27219"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby CGI library","requires_auth":"none","summary":"An attacker can cause a denial of service by sending extremely large cookies to applications using the Ruby CGI library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"cgi","vendor":"ruby-lang"}],"cvss":{"score":5.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"In the CGI gem before 0.4.2 for Ruby, the CGI::Cookie.parse method in the CGI library contains a potential Denial of Service (DoS) vulnerability. The method does not impose any limit on the length of the raw cookie value it processes. This oversight can lead to excessive resource consumption when parsing extremely large cookies.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CGI has Denial of Service (DoS) potential in Cookie.parse","id":"CVE-2025-27219","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":6,"n_references":2,"next":{"headline":"CGI has Regular Expression Denial of Service (ReDoS) potential in Util#escapeElement","id":"CVE-2025-27220"},"packages":[{"ecosystem":"RubyGems","fixed":["0.3.5.1"],"introduced":["0"],"last_affected":[],"package":"cgi","purl":null,"source":"GHSA-gh9q-2xrm-x6qv"},{"ecosystem":"RubyGems","fixed":["0.3.5.1"],"introduced":["0"],"last_affected":[],"package":"cgi","purl":"pkg:gem/cgi","source":"GHSA-gh9q-2xrm-x6qv"},{"ecosystem":"RubyGems","fixed":["0.3.7"],"introduced":["0.3.6"],"last_affected":[],"package":"cgi","purl":null,"source":"GHSA-gh9q-2xrm-x6qv"},{"ecosystem":"RubyGems","fixed":["0.3.7"],"introduced":["0.3.6"],"last_affected":[],"package":"cgi","purl":"pkg:gem/cgi","source":"GHSA-gh9q-2xrm-x6qv"},{"ecosystem":"RubyGems","fixed":["0.4.2"],"introduced":["0.4.0"],"last_affected":[],"package":"cgi","purl":null,"source":"GHSA-gh9q-2xrm-x6qv"},{"ecosystem":"RubyGems","fixed":["0.4.2"],"introduced":["0.4.0"],"last_affected":[],"package":"cgi","purl":"pkg:gem/cgi","source":"GHSA-gh9q-2xrm-x6qv"}],"prev":{"headline":"Deserialization in n/a","id":"CVE-2025-27218"},"products":["CGI"],"published":"2025-03-03","related":[{"cvss_score":4,"headline":"CGI has Regular Expression Denial of Service (ReDoS) potential in Util#escapeElement","id":"CVE-2025-27220","kev_date_added":null,"published":"2025-03-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["ruby-lang"]},"summary":"An attacker can cause a denial of service by sending extremely large cookies to applications using the Ruby CGI library.","url":"https://insights.sbomify.com/CVE-2025-27219/"}