{"answers":{"affected":"8 open source packages ship an affected version, including uri. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-27221 in the wild and no public exploit code.","fix":"Upgrade uri to a fixed version for your release line: 0.11.3, 0.12.4, 0.13.2 or 1.0.3.","what":"CVE-2025-27221 is a low-severity vulnerability in ruby-lang URI, published on 3 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-27221 and fix it if it is affected.\n\nWhat it is: CVE-2025-27221 is a low-severity vulnerability in ruby-lang URI, published on 3 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-27221 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- uri (RubyGems): affected all versions; fixed in 0.11.3\n- uri (RubyGems): affected all versions; fixed in 0.11.3\n- uri (RubyGems): affected from 0.12.0; fixed in 0.12.4\n- uri (RubyGems): affected from 0.12.0; fixed in 0.12.4\n- uri (RubyGems): affected from 0.13.0; fixed in 0.13.2\n- uri (RubyGems): affected from 0.13.0; fixed in 0.13.2\n- uri (RubyGems): affected from 1.0.0; fixed in 1.0.3\n- uri (RubyGems): affected from 1.0.0; fixed in 1.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-27221/ (Markdown: https://insights.sbomify.com/CVE-2025-27221/index.md)","id":"CVE-2025-27221","markdown":"https://insights.sbomify.com/CVE-2025-27221/index.md","name":"CVE-2025-27221","record":{"aliases":["AZL-57778","AZL-57893","CLEANSTART-2026-JV54364","CLEANSTART-2026-RX39488","CLSA-2026-1768314331","DEBIAN-CVE-2025-27221","ECHO-0f02-8857-9466","GHSA-22h5-pq3x-2gf2","MINI-6c4r-w2x8-j455","MINI-6h56-9hp5-pv35","MINI-99gx-v4vj-qrx8","MINI-9x5x-9qgw-wrhq","MINI-fm47-8mvq-9f46","MINI-g2r5-q7w6-mmf2","MINI-g36m-x3vr-xg5w","MINI-gfcv-pr58-vg2w","MINI-h375-x4hx-vg53","MINI-q6qw-jj6h-f3h9","MINI-wp63-cqhf-vf9g","MINI-wv4q-r7rh-gwrf","MINI-x3ch-cgwc-f4m9","MINI-xqqg-375w-hwcg","UBUNTU-CVE-2025-27221"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ruby URI library","requires_auth":"none","summary":"Attackers can leak authentication credentials when URI methods retain userinfo after host changes, affecting Ruby applications using the URI gem.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"uri","vendor":"ruby-lang"}],"cvss":{"score":3.2,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-212","name":"Improper Removal of Sensitive Information Before Storage or Transfer"}],"description":"In the URI gem before 1.0.3 for Ruby, the URI handling methods (URI.join, URI#merge, URI#+) have an inadvertent leakage of authentication credentials because userinfo is retained even after changing the host.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"URI allows for userinfo Leakage in URI#join, URI#merge, and URI#+","id":"CVE-2025-27221","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":8,"n_references":2,"next":{"headline":"Path traversal in n/a","id":"CVE-2025-27222"},"packages":[{"ecosystem":"RubyGems","fixed":["0.11.3"],"introduced":["0"],"last_affected":[],"package":"uri","purl":null,"source":"GHSA-22h5-pq3x-2gf2"},{"ecosystem":"RubyGems","fixed":["0.11.3"],"introduced":["0"],"last_affected":[],"package":"uri","purl":"pkg:gem/uri","source":"GHSA-22h5-pq3x-2gf2"},{"ecosystem":"RubyGems","fixed":["0.12.4"],"introduced":["0.12.0"],"last_affected":[],"package":"uri","purl":null,"source":"GHSA-22h5-pq3x-2gf2"},{"ecosystem":"RubyGems","fixed":["0.12.4"],"introduced":["0.12.0"],"last_affected":[],"package":"uri","purl":"pkg:gem/uri","source":"GHSA-22h5-pq3x-2gf2"},{"ecosystem":"RubyGems","fixed":["0.13.2"],"introduced":["0.13.0"],"last_affected":[],"package":"uri","purl":null,"source":"GHSA-22h5-pq3x-2gf2"},{"ecosystem":"RubyGems","fixed":["0.13.2"],"introduced":["0.13.0"],"last_affected":[],"package":"uri","purl":"pkg:gem/uri","source":"GHSA-22h5-pq3x-2gf2"},{"ecosystem":"RubyGems","fixed":["1.0.3"],"introduced":["1.0.0"],"last_affected":[],"package":"uri","purl":null,"source":"GHSA-22h5-pq3x-2gf2"},{"ecosystem":"RubyGems","fixed":["1.0.3"],"introduced":["1.0.0"],"last_affected":[],"package":"uri","purl":"pkg:gem/uri","source":"GHSA-22h5-pq3x-2gf2"}],"prev":{"headline":"CGI has Regular Expression Denial of Service (ReDoS) potential in Util#escapeElement","id":"CVE-2025-27220"},"products":["URI"],"published":"2025-03-03","related":[{"cvss_score":5.3,"headline":"URI gem has ReDoS vulnerability","id":"CVE-2023-36617","kev_date_added":null,"published":"2023-06-29"},{"cvss_score":2.1,"headline":"URI Credential Leakage Bypass over CVE-2025-27221","id":"CVE-2025-61594","kev_date_added":null,"published":"2025-12-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["ruby-lang"]},"summary":"Attackers can leak authentication credentials when URI methods retain userinfo after host changes, affecting Ruby applications using the URI gem.","url":"https://insights.sbomify.com/CVE-2025-27221/"}