{"answers":{"affected":"2 open source packages ship an affected version, including openmage/magento-lts.","exploited":"There is no known exploitation of CVE-2025-27400 in the wild and no public exploit code.","fix":"Upgrade openmage/magento-lts to 20.12.3 or later.","what":"CVE-2025-27400 is a low-severity cross-site scripting vulnerability in OpenMage magento-lts, published on 28 Feb 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-27400 and fix it if it is affected.\n\nWhat it is: CVE-2025-27400 is a low-severity cross-site scripting vulnerability in OpenMage magento-lts, published on 28 Feb 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-27400 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openmage/magento-lts (Packagist): affected all versions; fixed in 20.12.3\n- openmage/magento-lts (Packagist): affected all versions; fixed in 20.12.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-27400/ (Markdown: https://insights.sbomify.com/CVE-2025-27400/index.md)","id":"CVE-2025-27400","markdown":"https://insights.sbomify.com/CVE-2025-27400/index.md","name":"CVE-2025-27400","record":{"aliases":["GHSA-5pxh-89cx-4668"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Magento LTS","requires_auth":"high_privilege","summary":"Authenticated admin users can execute scripts via stored XSS in theme config fields, potentially compromising the admin panel.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":2.9,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Versions prior to 20.12.3 and 20.13.0 contain a vulnerability that allows script execution in the admin panel which could lead to cross-site scripting against authenticated admin users. The attack requires an admin user with configuration access, so in practicality it is not very likely to be useful given that a user with this level of access is probably already a full admin. Versions 20.12.3 and 20.13.0 contain a patch for the issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Magento vulnerable to stored XSS in theme config fields","id":"CVE-2025-27400","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":4,"next":{"headline":"In Tuleap, deleting a report can delete criteria filters in other reports","id":"CVE-2025-27401"},"packages":[{"ecosystem":"Packagist","fixed":["20.12.3"],"introduced":["0"],"last_affected":[],"package":"openmage/magento-lts","purl":null,"source":"GHSA-5pxh-89cx-4668"},{"ecosystem":"Packagist","fixed":["20.12.3"],"introduced":["0"],"last_affected":[],"package":"openmage/magento-lts","purl":"pkg:composer/openmage/magento-lts","source":"GHSA-5pxh-89cx-4668"}],"prev":{"headline":"Mastodon's domain blocks \u0026 rationales ignore user approval when visibility set as \"users\"","id":"CVE-2025-27399"},"products":["magento-lts"],"published":"2025-02-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-26","vendors":["OpenMage"]},"summary":"Authenticated admin users can execute scripts via stored XSS in theme config fields, potentially compromising the admin panel.","url":"https://insights.sbomify.com/CVE-2025-27400/"}