# CVE-2025-27400: Magento vulnerable to stored XSS in theme config fields

> Authenticated admin users can execute scripts via stored XSS in theme config fields, potentially compromising the admin panel.

- **Severity:** Low 2.9 (`CVSS:3.1/AV:A/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Feb 2025
- **Updated:** 26 Aug 2025
- **Also known as:** GHSA-5pxh-89cx-4668

## What is CVE-2025-27400?

CVE-2025-27400 is a low-severity cross-site scripting vulnerability in OpenMage magento-lts, published on 28 Feb 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Versions prior to 20.12.3 and 20.13.0 contain a vulnerability that allows script execution in the admin panel which could lead to cross-site scripting against authenticated admin users. The attack requires an admin user with configuration access, so in practicality it is not very likely to be useful given that a user with this level of access is probably already a full admin. Versions 20.12.3 and 20.13.0 contain a patch for the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-27400?

2 open source packages ship an affected version, including openmage/magento-lts.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openmage/magento-lts` | Packagist | All versions | 20.12.3 |
| `openmage/magento-lts` | Packagist | All versions | 20.12.3 |

## How do I fix CVE-2025-27400?

Upgrade openmage/magento-lts to 20.12.3 or later.

## Is CVE-2025-27400 being exploited?

There is no known exploitation of CVE-2025-27400 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27400 and fix it if it is affected.

What it is: CVE-2025-27400 is a low-severity cross-site scripting vulnerability in OpenMage magento-lts, published on 28 Feb 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-27400 in the wild and no public exploit code.

Affected packages and fixed versions:
- openmage/magento-lts (Packagist): affected all versions; fixed in 20.12.3
- openmage/magento-lts (Packagist): affected all versions; fixed in 20.12.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27400/ (Markdown: https://insights.sbomify.com/CVE-2025-27400/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27400
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27400
- OSV: https://osv.dev/vulnerability/CVE-2025-27400

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27400/
Summaries are generated and may contain mistakes; the official description above is the record.
