# CVE-2025-27408: Manifest Uses a One-Way Hash without a Salt

> Attackers can crack user passwords more easily due to unsalted SHA3 hashing if they access the database, affecting Manifest backend users.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Feb 2025
- **Updated:** 4 Mar 2025
- **Also known as:** GHSA-h8h6-7752-g28c

## What is CVE-2025-27408?

CVE-2025-27408 is a medium-severity vulnerability in mnfst manifest, published on 28 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Manifest offers users a one-file micro back end. Prior to version 4.9.2, Manifest employs a weak password hashing implementation that uses SHA3 without a salt. This exposes user passwords to a higher risk of being cracked if an attacker gains access to the database. Without the use of a salt, identical passwords across multiple users will result in the same hash, making it easier for attackers to identify and exploit patterns, thereby accelerating the cracking process. Version 4.9.2 fixes the issue.

Weakness: CWE-759 (Use of a One-Way Hash without a Salt)

## Which versions are affected by CVE-2025-27408?

2 open source packages ship an affected version, including manifest.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `manifest` | npm | All versions | 4.9.2 |
| `manifest` | npm | All versions | 4.9.2 |

## How do I fix CVE-2025-27408?

Upgrade manifest to 4.9.2 or later.

## Is CVE-2025-27408 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27408 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27408 and fix it if it is affected.

What it is: CVE-2025-27408 is a medium-severity vulnerability in mnfst manifest, published on 28 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27408 exists.

Affected packages and fixed versions:
- manifest (npm): affected all versions; fixed in 4.9.2
- manifest (npm): affected all versions; fixed in 4.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27408/ (Markdown: https://insights.sbomify.com/CVE-2025-27408/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27408
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27408
- OSV: https://osv.dev/vulnerability/CVE-2025-27408

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27408/
Summaries are generated and may contain mistakes; the official description above is the record.
