CVE-2025-27412 REDAXO allows Authenticated Reflected Cross Site Scripting - packages installation

Medium 6.1 Published Updated

Authenticated attackers can execute arbitrary scripts via reflected XSS in the REDAXO CMS AddOns installation page.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-27412?

CVE-2025-27412 is a medium-severity cross-site scripting vulnerability in redaxo, published on 5 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

REDAXO is a PHP-based CMS. In Redaxo from 5.0.0 through 5.18.2, the rex-api-result parameter is vulnerable to Reflected cross-site scripting (XSS) on the page of AddOns. This vulnerability is fixed in 5.18.3.

Weakness: CWE-79

Which versions are affected by CVE-2025-27412?

2 open source packages ship an affected version, including redaxo/source. It affects 1 product.

PackageAffectedFixed in
redaxo/source PackagistFrom 5.0.05.18.3
redaxo/source PackagistFrom 5.0.05.18.3

Products include Redaxo Redaxo.

How do I fix CVE-2025-27412?

Upgrade redaxo/source to 5.18.3 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-27412 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27412 exists.

Sources

Also known as GHSA-8366-xmgf-334f.

Is CVE-2025-27412 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free