# CVE-2025-27415: Nuxt allows DOS via cache poisoning with payload rendering response

> Attackers can poison CDN caches via crafted requests, causing permanent denial of service for sites using Nuxt behind misconfigured CDNs.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Mar 2025
- **Updated:** 19 Mar 2025
- **Also known as:** GHSA-jvhm-gjrh-3h93

## What is CVE-2025-27415?

CVE-2025-27415 is a high-severity denial of service vulnerability in nuxt, published on 19 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nuxt is an open-source web development framework for Vue.js. Prior to 3.16.0, by sending a crafted HTTP request to a server behind an CDN, it is possible in some circumstances to poison the CDN cache and highly impacts the availability of a site. It is possible to craft a request, such as https://mysite.com/?/_payload.json which will be rendered as JSON. If the CDN in front of a Nuxt site ignores the query string when determining whether to cache a route, then this JSON response could be served to future visitors to the site. An attacker can perform this attack to a vulnerable site in order to make a site unavailable indefinitely. It is also possible in the case where the cache will be reset to make a small script to send a request each X seconds (=caching duration) so that the cache is permanently poisoned making the site completely unavailable. This vulnerability is fixed in 3.16.0.

Weakness: CWE-349 (Acceptance of Extraneous Untrusted Data With Trusted Data)

## Which versions are affected by CVE-2025-27415?

2 open source packages ship an affected version, including nuxt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nuxt` | npm | From 3.0.0 | 3.16.0 |
| `nuxt` | npm | From 3.0.0 | 3.16.0 |

Products: Nuxt Nuxt.

## How do I fix CVE-2025-27415?

Upgrade nuxt to 3.16.0 or later.

## Is CVE-2025-27415 being exploited?

There is no known exploitation of CVE-2025-27415 in the wild and no public exploit code.

Public exploit code:

- Nuxt3 Acceptance of Extraneous Untrusted Data With Trusted Data vulnerability (github_poc): https://github.com/jiseoung/CVE-2025-27415-PoC

## Other vulnerabilities in nuxt

- [CVE-2026-53721](https://insights.sbomify.com/CVE-2026-53721/): Nuxt: Route-rule middleware bypass via case-sensitivity mismatch between vue-router and the routeRules matcher (high 8.8)
- [CVE-2024-23657](https://insights.sbomify.com/CVE-2024-23657/): Path Traversal: '../filedir' in Nuxt Devtools (high 8.8)
- [CVE-2024-34344](https://insights.sbomify.com/CVE-2024-34344/): Remote code execution via the browser when running the test locally in nuxt (high 8.8)
- [CVE-2024-42352](https://insights.sbomify.com/CVE-2024-42352/): Server-Side Request Forgery (SSRF) in nuxt-icon (high 8.6)
- [CVE-2023-3224](https://insights.sbomify.com/CVE-2023-3224/): Code Injection in nuxt/nuxt (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27415 and fix it if it is affected.

What it is: CVE-2025-27415 is a high-severity denial of service vulnerability in nuxt, published on 19 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27415 in the wild and no public exploit code.

Affected packages and fixed versions:
- nuxt (npm): affected from 3.0.0; fixed in 3.16.0
- nuxt (npm): affected from 3.0.0; fixed in 3.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27415/ (Markdown: https://insights.sbomify.com/CVE-2025-27415/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27415
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27415
- OSV: https://osv.dev/vulnerability/CVE-2025-27415

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27415/
Summaries are generated and may contain mistakes; the official description above is the record.
