# CVE-2025-27427: Apache ActiveMQ Artemis: Address routing-type can be updated by user without the createAddress permission

> Users with queue creation permissions can modify address routing types without address creation permissions, bypassing intended access controls.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2025
- **Updated:** 2 Apr 2025
- **Also known as:** CLSA-2026-1780966327, CLSA-2026-1786943805, CLSA-2026-1789384355, GHSA-3w85-5p9g-h334, ROOT-APP-MAVEN-CVE-2025-27427

## What is CVE-2025-27427?

CVE-2025-27427 is a low-severity missing authorization vulnerability in Apache ActiveMQ Artemis, published on 1 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability exists in Apache ActiveMQ Artemis whereby a user with the createDurableQueue or createNonDurableQueue permission on an address can augment the routing-type supported by that address even if said user doesn't have the createAddress permission for that particular address. When combined with the send permission and automatic queue creation a user could successfully send a message with a routing-type not supported by the address when that message should actually be rejected on the basis that the user doesn't have permission to change the routing-type of the address.

This issue affects Apache ActiveMQ Artemis from 2.0.0 through 2.39.0.

Users are recommended to upgrade to version 2.40.0 which fixes the issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-27427?

2 open source packages ship an affected version, including org.apache.activemq:artemis-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:artemis-server` | Maven | From 2.0.0 | 2.40.0 |
| `org.apache.activemq:artemis-server` | Maven | From 2.0.0 | 2.40.0 |

Products: Apache Artemis.

## How do I fix CVE-2025-27427?

Upgrade org.apache.activemq:artemis-server to 2.40.0 or later.

## Is CVE-2025-27427 being exploited?

There is no known exploitation of CVE-2025-27427 in the wild and no public exploit code.

## Other vulnerabilities in Apache ActiveMQ Artemis

- [CVE-2026-57967](https://insights.sbomify.com/CVE-2026-57967/): Apache Artemis, Apache ActiveMQ Artemis: Missing authentication on CORE protocol session reattachment (critical 9.8)
- [CVE-2026-27446](https://insights.sbomify.com/CVE-2026-27446/): Apache Artemis, Apache ActiveMQ Artemis: Auth bypass for Core downstream federation (critical 9.3)
- [CVE-2026-49364](https://insights.sbomify.com/CVE-2026-49364/): Information disclosure in Apache ActiveMQ Artemis (critical 9.1)
- [CVE-2026-67593](https://insights.sbomify.com/CVE-2026-67593/): Missing authorization in Apache ActiveMQ Artemis (critical 9.1)
- [CVE-2023-50780](https://insights.sbomify.com/CVE-2023-50780/): Apache ActiveMQ Artemis: Authenticated users could perform RCE via Jolokia MBeans (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27427 and fix it if it is affected.

What it is: CVE-2025-27427 is a low-severity missing authorization vulnerability in Apache ActiveMQ Artemis, published on 1 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27427 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.activemq:artemis-server (Maven): affected from 2.0.0; fixed in 2.40.0
- org.apache.activemq:artemis-server (Maven): affected from 2.0.0; fixed in 2.40.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27427/ (Markdown: https://insights.sbomify.com/CVE-2025-27427/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27427
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27427
- OSV: https://osv.dev/vulnerability/CVE-2025-27427

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27427/
Summaries are generated and may contain mistakes; the official description above is the record.
