CVE-2025-27446 Privilege escalation in Apache APISIX Java Plugin Runner
A local attacker can elevate privileges due to incorrect permissions on the local listening file in the APISIX Java Plugin Runner.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-27446?
CVE-2025-27446 is a high-severity vulnerability in Apache APISIX Java Plugin Runner, published on 6 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Incorrect Permission Assignment for Critical Resource vulnerability in Apache APISIX(java-plugin-runner).
Local listening file permissions in APISIX plugin runner allow a local attacker to elevate privileges. This issue affects Apache APISIX(java-plugin-runner): from 0.2.0 through 0.5.0.
Users are recommended to upgrade to version 0.6.0 or higher, which fixes the issue.
Weakness: CWE-732
Which versions are affected by CVE-2025-27446?
1 open source package ship an affected version, including apisix. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apisix Bitnami | From 0.2.0 | 3.9.0 |
Products include Apache Apisix.
How do I fix CVE-2025-27446?
Upgrade apisix to 3.9.0 or later.
Is CVE-2025-27446 being exploited?
There is no known exploitation of CVE-2025-27446 in the wild and no public exploit code.
Other vulnerabilities in Apache APISIX Java Plugin Runner
- CVE-2022-24112 Apache APISIX Authentication Bypass
- CVE-2022-25757 Apache APISIX: the body_schema check in request-validation plugin can be bypassed
- CVE-2026-31908 Apache APISIX: forward auth plugin allows header injection
- CVE-2026-75005 Apache APISIX: Unauthenticated CPU-exhaustion DoS
- CVE-2026-31923 Apache APISIX: Openid-connect `tls_verify` field is disabled by default
Sources
Also known as BIT-apisix-2025-27446, GHSA-xm8v-g828-5x9r.