# CVE-2025-27446: Privilege escalation in Apache APISIX Java Plugin Runner

> A local attacker can elevate privileges due to incorrect permissions on the local listening file in the APISIX Java Plugin Runner.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2025
- **Updated:** 26 Feb 2026
- **Also known as:** BIT-apisix-2025-27446, GHSA-xm8v-g828-5x9r

## What is CVE-2025-27446?

CVE-2025-27446 is a high-severity vulnerability in Apache APISIX Java Plugin Runner, published on 6 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Incorrect Permission Assignment for Critical Resource vulnerability in Apache APISIX(java-plugin-runner).

Local listening file permissions in APISIX plugin runner allow a local attacker to elevate privileges.
This issue affects Apache APISIX(java-plugin-runner): from 0.2.0 through 0.5.0.

Users are recommended to upgrade to version 0.6.0 or higher, which fixes the issue.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2025-27446?

1 open source package ship an affected version, including apisix. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apisix` | Bitnami | From 0.2.0 | 3.9.0 |

Products: Apache Apisix.

## How do I fix CVE-2025-27446?

Upgrade apisix to 3.9.0 or later.

## Is CVE-2025-27446 being exploited?

There is no known exploitation of CVE-2025-27446 in the wild and no public exploit code.

## Other vulnerabilities in Apache APISIX Java Plugin Runner

- [CVE-2022-24112](https://insights.sbomify.com/CVE-2022-24112/): Apache APISIX Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2022-25757](https://insights.sbomify.com/CVE-2022-25757/): Apache APISIX: the body_schema check in request-validation plugin can be bypassed (critical 9.8)
- [CVE-2026-31908](https://insights.sbomify.com/CVE-2026-31908/): Apache APISIX: forward auth plugin allows header injection (critical 9.1)
- [CVE-2026-75005](https://insights.sbomify.com/CVE-2026-75005/): Apache APISIX: Unauthenticated CPU-exhaustion DoS (high 8.7)
- [CVE-2026-31923](https://insights.sbomify.com/CVE-2026-31923/): Apache APISIX: Openid-connect `tls_verify` field is disabled by default (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27446 and fix it if it is affected.

What it is: CVE-2025-27446 is a high-severity vulnerability in Apache APISIX Java Plugin Runner, published on 6 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27446 in the wild and no public exploit code.

Affected packages and fixed versions:
- apisix (Bitnami): affected from 0.2.0; fixed in 3.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27446/ (Markdown: https://insights.sbomify.com/CVE-2025-27446/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27446
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27446
- OSV: https://osv.dev/vulnerability/CVE-2025-27446

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27446/
Summaries are generated and may contain mistakes; the official description above is the record.
