# CVE-2025-27497: OpenDJ Denial of Service (Dos) using alias loop

> An attacker can cause the OpenDJ LDAP server to become unresponsive by triggering an alias loop during a search request.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2025
- **Updated:** 5 Mar 2025
- **Also known as:** GHSA-93qr-h8pr-4593

## What is CVE-2025-27497?

CVE-2025-27497 is a high-severity denial of service vulnerability in OpenIdentityPlatform OpenDJ, published on 5 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenDJ is an LDAPv3 compliant directory service. OpenDJ prior to 4.9.3 contains a denial-of-service (DoS) vulnerability that causes the server to become unresponsive to all LDAP requests without crashing or restarting. This issue occurs when an alias loop exists in the LDAP database. If an ldapsearch request is executed with alias dereferencing set to "always" on this alias entry, the server stops responding to all future requests. Fortunately, the server can be restarted without data corruption. This vulnerability is fixed in 4.9.3.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2025-27497?

2 open source packages ship an affected version, including org.openidentityplatform.opendj:opendj-server-legacy.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.openidentityplatform.opendj:opendj-server-legacy` | Maven | All versions | 4.9.3 |
| `org.openidentityplatform.opendj:opendj-server-legacy` | Maven | All versions | 4.9.3 |

## How do I fix CVE-2025-27497?

Upgrade org.openidentityplatform.opendj:opendj-server-legacy to 4.9.3 or later.

## Is CVE-2025-27497 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27497 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27497 and fix it if it is affected.

What it is: CVE-2025-27497 is a high-severity denial of service vulnerability in OpenIdentityPlatform OpenDJ, published on 5 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27497 exists.

Affected packages and fixed versions:
- org.openidentityplatform.opendj:opendj-server-legacy (Maven): affected all versions; fixed in 4.9.3
- org.openidentityplatform.opendj:opendj-server-legacy (Maven): affected all versions; fixed in 4.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27497/ (Markdown: https://insights.sbomify.com/CVE-2025-27497/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27497
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27497
- OSV: https://osv.dev/vulnerability/CVE-2025-27497

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27497/
Summaries are generated and may contain mistakes; the official description above is the record.
