# CVE-2025-27506: NocoDB Vulnerable to Reflected Cross-Site Scripting on Reset Password Page

> Attackers can execute arbitrary scripts in victims' browsers via the password reset page, potentially leading to account takeover.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Mar 2025
- **Updated:** 6 Mar 2025
- **Also known as:** GHSA-wf6c-hrhf-86cw

## What is CVE-2025-27506?

CVE-2025-27506 is a medium-severity cross-site scripting vulnerability in nocodb, published on 6 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

NocoDB is software for building databases as spreadsheets. The API endpoint related to the password reset function is vulnerable to Reflected Cross-Site-Scripting. The endpoint /api/v1/db/auth/password/reset/:tokenId is vulnerable to Reflected Cross-Site-Scripting. The flaw occurs due to implementation of the client-side template engine ejs, specifically on file resetPassword.ts where the template is using the insecure function “<%-“, which is rendered by the function renderPasswordReset. This vulnerability is fixed in 0.258.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-27506?

2 open source packages ship an affected version, including nocodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nocodb` | npm | All versions | 0.258.0 |
| `nocodb` | npm | All versions | 0.258.0 |

Products: Nocodb Nocodb.

## How do I fix CVE-2025-27506?

Upgrade nocodb to 0.258.0 or later.

## Is CVE-2025-27506 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27506 exists.

Public exploit code:

- NocoDB < 0.258.0 - Reflected XSS in Password Reset (nuclei): http/cves/2025/CVE-2025-27506.yaml

## Other vulnerabilities in nocodb

- [CVE-2022-2339](https://insights.sbomify.com/CVE-2022-2339/): Server-Side Request Forgery (SSRF) in nocodb/nocodb (critical 9.1)
- [CVE-2022-2062](https://insights.sbomify.com/CVE-2022-2062/): Generation of Error Message Containing Sensitive Information in nocodb/nocodb (critical 9.1)
- [CVE-2022-2064](https://insights.sbomify.com/CVE-2022-2064/): Insufficient Session Expiration in nocodb/nocodb (critical 9.1)
- [CVE-2022-2063](https://insights.sbomify.com/CVE-2022-2063/): Improper Privilege Management in nocodb/nocodb (critical 9.0)
- [CVE-2022-2022](https://insights.sbomify.com/CVE-2022-2022/): Cross-site Scripting (XSS) - Stored in nocodb/nocodb (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27506 and fix it if it is affected.

What it is: CVE-2025-27506 is a medium-severity cross-site scripting vulnerability in nocodb, published on 6 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27506 exists.

Affected packages and fixed versions:
- nocodb (npm): affected all versions; fixed in 0.258.0
- nocodb (npm): affected all versions; fixed in 0.258.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27506/ (Markdown: https://insights.sbomify.com/CVE-2025-27506/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27506
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27506
- OSV: https://osv.dev/vulnerability/CVE-2025-27506

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27506/
Summaries are generated and may contain mistakes; the official description above is the record.
