{"answers":{"affected":"2 open source packages ship an affected version, including gov.nsa.emissary:emissary.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27508 exists.","fix":"Upgrade gov.nsa.emissary:emissary to 8.24.0 or later.","what":"CVE-2025-27508 is a high-severity vulnerability in NationalSecurityAgency emissary, published on 5 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-27508 and fix it if it is affected.\n\nWhat it is: CVE-2025-27508 is a high-severity vulnerability in NationalSecurityAgency emissary, published on 5 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27508 exists.\n\nAffected packages and fixed versions:\n- gov.nsa.emissary:emissary (Maven): affected all versions; fixed in 8.24.0\n- gov.nsa.emissary:emissary (Maven): affected all versions; fixed in 8.24.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-27508/ (Markdown: https://insights.sbomify.com/CVE-2025-27508/index.md)","id":"CVE-2025-27508","markdown":"https://insights.sbomify.com/CVE-2025-27508/index.md","name":"CVE-2025-27508","record":{"aliases":["GHSA-hw43-fcmm-3m5g"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Emissary workflow engine","requires_auth":"none","summary":"Emissary defaults to weak cryptographic algorithms like SHA-1, potentially compromising data integrity and security guarantees for users relying on its checksum features.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-327","name":"Use of a Broken or Risky Cryptographic Algorithm"}],"description":"Emissary is a P2P based data-driven workflow engine. The ChecksumCalculator class within allows for hashing and checksum generation, but it includes or defaults to algorithms that are no longer recommended for secure cryptographic use cases (e.g., SHA-1, CRC32, and SSDEEP). These algorithms, while possibly valid for certain non-security-critical tasks, can expose users to security risks if used in scenarios where strong cryptographic guarantees are required. This issue is fixed in 8.24.0.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Emissary Use of a Broken or Risky Cryptographic Algorithm","id":"CVE-2025-27508","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"weak_cryptography","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"SAML authentication vulnerability due to improper SAML response validation","id":"CVE-2025-27509"},"packages":[{"ecosystem":"Maven","fixed":["8.24.0"],"introduced":["0"],"last_affected":[],"package":"gov.nsa.emissary:emissary","purl":null,"source":"GHSA-hw43-fcmm-3m5g"},{"ecosystem":"Maven","fixed":["8.24.0"],"introduced":["0"],"last_affected":[],"package":"gov.nsa.emissary:emissary","purl":"pkg:maven/gov.nsa.emissary/emissary","source":"GHSA-hw43-fcmm-3m5g"}],"prev":{"headline":"IDOR Vulnerabilities in ZITADEL's Admin API that Primarily Impact LDAP Configurations","id":"CVE-2025-27507"},"products":["emissary"],"published":"2025-03-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-07","vendors":["NationalSecurityAgency"]},"summary":"Emissary defaults to weak cryptographic algorithms like SHA-1, potentially compromising data integrity and security guarantees for users relying on its checksum features.","url":"https://insights.sbomify.com/CVE-2025-27508/"}