# CVE-2025-27508: Emissary Use of a Broken or Risky Cryptographic Algorithm

> Emissary defaults to weak cryptographic algorithms like SHA-1, potentially compromising data integrity and security guarantees for users relying on its checksum features.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2025
- **Updated:** 7 Mar 2025
- **Also known as:** GHSA-hw43-fcmm-3m5g

## What is CVE-2025-27508?

CVE-2025-27508 is a high-severity vulnerability in NationalSecurityAgency emissary, published on 5 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Emissary is a P2P based data-driven workflow engine. The ChecksumCalculator class within allows for hashing and checksum generation, but it includes or defaults to algorithms that are no longer recommended for secure cryptographic use cases (e.g., SHA-1, CRC32, and SSDEEP). These algorithms, while possibly valid for certain non-security-critical tasks, can expose users to security risks if used in scenarios where strong cryptographic guarantees are required. This issue is fixed in 8.24.0.

Weakness: CWE-327 (Use of a Broken or Risky Cryptographic Algorithm)

## Which versions are affected by CVE-2025-27508?

2 open source packages ship an affected version, including gov.nsa.emissary:emissary.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gov.nsa.emissary:emissary` | Maven | All versions | 8.24.0 |
| `gov.nsa.emissary:emissary` | Maven | All versions | 8.24.0 |

## How do I fix CVE-2025-27508?

Upgrade gov.nsa.emissary:emissary to 8.24.0 or later.

## Is CVE-2025-27508 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27508 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27508 and fix it if it is affected.

What it is: CVE-2025-27508 is a high-severity vulnerability in NationalSecurityAgency emissary, published on 5 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27508 exists.

Affected packages and fixed versions:
- gov.nsa.emissary:emissary (Maven): affected all versions; fixed in 8.24.0
- gov.nsa.emissary:emissary (Maven): affected all versions; fixed in 8.24.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27508/ (Markdown: https://insights.sbomify.com/CVE-2025-27508/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27508
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27508
- OSV: https://osv.dev/vulnerability/CVE-2025-27508

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27508/
Summaries are generated and may contain mistakes; the official description above is the record.
