# CVE-2025-27511: GeoServer DB2 DataStore Extension has a JNDI Vulnerability via Store Connection

> An administrator can achieve remote code execution via a JNDI attack using a crafted DB2 JDBC URL in the GeoServer DB2 DataStore Extension.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jun 2026
- **Updated:** 24 Jun 2026
- **Also known as:** GHSA-g628-r368-6vh7

## What is CVE-2025-27511?

CVE-2025-27511 is a high-severity unsafe deserialization vulnerability in org.geoserver.extension:gs-db2, published on 18 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

GeoServer is an open source server that allows users to share and edit geospatial data. Prior to version 2.27.0 of the GeoServer DB2 DataStore Extension, an administrator can perform a JNDI attack through specially crafted DB2 jdbc url leading to to Remote Code Execution (RCE). Version 2.27.0 fixes the issue.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-27511?

2 open source packages ship an affected version, including org.geoserver.extension:gs-db2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.geoserver.extension:gs-db2` | Maven | All versions | 2.27.0 |
| `org.geoserver.extension:gs-db2` | Maven | All versions | 2.27.0 |

Products: Osgeo Geoserver.

## How do I fix CVE-2025-27511?

Upgrade org.geoserver.extension:gs-db2 to 2.27.0 or later.

## Is CVE-2025-27511 being exploited?

There is no known exploitation of CVE-2025-27511 in the wild and no public exploit code.

## Other vulnerabilities in org.geoserver.extension:gs-db2

- [CVE-2023-25157](https://insights.sbomify.com/CVE-2023-25157/): Unfiltered SQL Injection Vulnerabilities in Geoserver (critical 9.8)
- [CVE-2024-34711](https://insights.sbomify.com/CVE-2024-34711/): GeoServer has improper ENTITY_RESOLUTION_ALLOWLIST URI validation in XML Processing (SSRF) (critical 9.3)
- [CVE-2023-41339](https://insights.sbomify.com/CVE-2023-41339/): Unsecured WMS dynamic styling sld=<url> parameter affords blind unauthenticated SSRF in GeoServer (high 8.6)
- [CVE-2023-43795](https://insights.sbomify.com/CVE-2023-43795/): WPS Server Side Request Forgery in GeoServer (high 8.6)
- [CVE-2024-29198](https://insights.sbomify.com/CVE-2024-29198/): GeoServer Vulnerable to Unauthenticated SSRF via TestWfsPost (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27511 and fix it if it is affected.

What it is: CVE-2025-27511 is a high-severity unsafe deserialization vulnerability in org.geoserver.extension:gs-db2, published on 18 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27511 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.geoserver.extension:gs-db2 (Maven): affected all versions; fixed in 2.27.0
- org.geoserver.extension:gs-db2 (Maven): affected all versions; fixed in 2.27.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27511/ (Markdown: https://insights.sbomify.com/CVE-2025-27511/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27511
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27511
- OSV: https://osv.dev/vulnerability/CVE-2025-27511

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27511/
Summaries are generated and may contain mistakes; the official description above is the record.
