{"answers":{"affected":"2 open source packages ship an affected version, including zincati.","exploited":"There is no known exploitation of CVE-2025-27512 in the wild and no public exploit code.","fix":"Upgrade zincati to 0.0.30 or later.","what":"CVE-2025-27512 is a low-severity missing authorization vulnerability in coreos zincati, published on 17 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-27512 and fix it if it is affected.\n\nWhat it is: CVE-2025-27512 is a low-severity missing authorization vulnerability in coreos zincati, published on 17 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-27512 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zincati (crates.io): affected from 0.0.24; fixed in 0.0.30\n- zincati (crates.io): affected from 0.0.24; fixed in 0.0.30\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-27512/ (Markdown: https://insights.sbomify.com/CVE-2025-27512/index.md)","id":"CVE-2025-27512","markdown":"https://insights.sbomify.com/CVE-2025-27512/index.md","name":"CVE-2025-27512","record":{"aliases":["GHSA-w6fv-6gcc-x825"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Fedora CoreOS update agent","requires_auth":"none","summary":"Unprivileged users can deploy older OS versions via D-Bus due to a flawed polkit rule in Zincati, potentially bypassing security controls.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":2.1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-783","name":"Operator Precedence Logic Error"}],"description":"Zincati is an auto-update agent for Fedora CoreOS hosts. Zincati ships a polkit rule which allows the `zincati` system user to use the actions `org.projectatomic.rpmostree1.deploy` to deploy updates to the system and `org.projectatomic.rpmostree1.finalize-deployment` to reboot the system into the deployed update. Since Zincati v0.0.24, this polkit rule contains a logic error which broadens access of those polkit actions to any unprivileged user rather than just the `zincati` system user. In practice, this means that any unprivileged user with access to the system D-Bus socket is able to deploy older Fedora CoreOS versions (which may have other known vulnerabilities). Note that rpm-ostree enforces that the selected version must be from the same branch the system is currently on so this cannot directly be used to deploy an attacker-controlled update payload. This primarily impacts users running untrusted workloads with access to the system D-Bus socket. Note that in general, untrusted workloads should not be given this access, whether containerized or not. By default, containers do not have access to the system D-Bus socket. The logic error is fixed in Zincati v0.0.30. A workaround is to manually add a following polkit rule, instructions for which are available in the GitHub Security Advisory.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Zincati allows unprivileged access to rpm-ostree D-Bus `Deploy()` and `FinalizeDeployment()` methods","id":"CVE-2025-27512","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"missing_authorization","year":"2025"},"n_packages":2,"n_references":5,"next":{"headline":"OpenTelemetry .NET has a Denial of Service (DoS) Vulnerability in API Package","id":"CVE-2025-27513"},"packages":[{"ecosystem":"crates.io","fixed":["0.0.30"],"introduced":["0.0.24"],"last_affected":[],"package":"zincati","purl":null,"source":"GHSA-w6fv-6gcc-x825"},{"ecosystem":"crates.io","fixed":["0.0.30"],"introduced":["0.0.24"],"last_affected":[],"package":"zincati","purl":"pkg:cargo/zincati","source":"GHSA-w6fv-6gcc-x825"}],"prev":{"headline":"GeoServer DB2 DataStore Extension has a JNDI Vulnerability via Store Connection","id":"CVE-2025-27511"},"products":["zincati"],"published":"2025-03-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-17","vendors":["coreos"]},"summary":"Unprivileged users can deploy older OS versions via D-Bus due to a flawed polkit rule in Zincati, potentially bypassing security controls.","url":"https://insights.sbomify.com/CVE-2025-27512/"}