CVE-2025-27514 GLPI is susceptible to Stored XSS attack through project's kanban
A technician can inject malicious scripts into the project kanban, leading to stored XSS attacks against other users.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2025-27514?
CVE-2025-27514 is a medium-severity cross-site scripting vulnerability in Glpi-Project Glpi, published on 29 Jul 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
GLPI is a Free Asset and IT Management Software package, Data center management, ITIL Service Desk, licenses tracking and software auditing. In versions 9.5.0 through 10.0.18, a technician can use a malicious payload to trigger a stored XSS on the project's kanban. This is fixed in version 10.0.19.
Which versions are affected by CVE-2025-27514?
It affects 1 product.
Products include Glpi-Project Glpi.
How do I fix CVE-2025-27514?
No fix has been published for CVE-2025-27514 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-27514 being exploited?
There is no known exploitation of CVE-2025-27514 in the wild and no public exploit code.
Other vulnerabilities in Glpi-Project Glpi
- CVE-2022-35914 Teclib GLPI Remote Code Execution
- CVE-2023-42802 GLPI vulnerable to unallowed PHP script execution
- CVE-2023-28849 GLPI vulnerable to SQL injection and Stored XSS via inventory agent request
- CVE-2022-35947 SQL injection in GLPI
- CVE-2022-31056 SQL injection with _actor parameter in GLPI
Sources
Also known as GHSA-jh8j-gqxc-6gqj, UBUNTU-CVE-2025-27514.