{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-27514 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-27514 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-27514 is a medium-severity cross-site scripting vulnerability in Glpi-Project Glpi, published on 29 Jul 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-27514 and fix it if it is affected.\n\nWhat it is: CVE-2025-27514 is a medium-severity cross-site scripting vulnerability in Glpi-Project Glpi, published on 29 Jul 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-27514 in the wild and no public exploit code.\n\nAffected product: Glpi-Project Glpi. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-27514/ (Markdown: https://insights.sbomify.com/CVE-2025-27514/index.md)","id":"CVE-2025-27514","markdown":"https://insights.sbomify.com/CVE-2025-27514/index.md","name":"CVE-2025-27514","record":{"aliases":["GHSA-jh8j-gqxc-6gqj","UBUNTU-CVE-2025-27514"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"IT management software","requires_auth":"high_privilege","summary":"A technician can inject malicious scripts into the project kanban, leading to stored XSS attacks against other users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"glpi","vendor":"glpi-project"}],"cvss":{"score":4.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"GLPI is a Free Asset and IT Management Software package, Data center management, ITIL Service Desk, licenses tracking and software auditing. In versions 9.5.0 through 10.0.18, a technician can use a malicious payload to trigger a stored XSS on the project's kanban. This is fixed in version 10.0.19.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"GLPI is susceptible to Stored XSS attack through project's kanban","id":"CVE-2025-27514","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"glpi-project:glpi","products":["glpi-project:glpi"],"type":"xss","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"Laravel has a File Validation Bypass","id":"CVE-2025-27515"},"packages":[],"prev":{"headline":"OpenTelemetry .NET has a Denial of Service (DoS) Vulnerability in API Package","id":"CVE-2025-27513"},"products":["glpi"],"published":"2025-07-29","related":[{"cvss_score":9.8,"headline":"Teclib GLPI Remote Code Execution","id":"CVE-2022-35914","kev_date_added":"2023-03-07","published":"2022-09-19"},{"cvss_score":10,"headline":"GLPI vulnerable to unallowed PHP script execution","id":"CVE-2023-42802","kev_date_added":null,"published":"2023-11-02"},{"cvss_score":10,"headline":"GLPI vulnerable to SQL injection and Stored XSS via inventory agent request","id":"CVE-2023-28849","kev_date_added":null,"published":"2023-04-05"},{"cvss_score":10,"headline":"SQL injection in GLPI","id":"CVE-2022-35947","kev_date_added":null,"published":"2022-09-14"},{"cvss_score":9.8,"headline":"SQL injection with _actor parameter in GLPI","id":"CVE-2022-31056","kev_date_added":null,"published":"2022-06-28"},{"cvss_score":9.8,"headline":"SQL injection on login page in GLPI","id":"CVE-2022-31061","kev_date_added":null,"published":"2022-06-28"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2021-44617","kev_date_added":null,"published":"2022-03-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-07-29","vendors":["glpi-project"]},"summary":"A technician can inject malicious scripts into the project kanban, leading to stored XSS attacks against other users.","url":"https://insights.sbomify.com/CVE-2025-27514/"}