{"answers":{"affected":"2 open source packages ship an affected version, including livewire/volt.","exploited":"There is no known exploitation of CVE-2025-27517 in the wild and no public exploit code.","fix":"Upgrade livewire/volt to 1.7.0 or later.","what":"CVE-2025-27517 is a critical code injection vulnerability in livewire volt, published on 5 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-27517 and fix it if it is affected.\n\nWhat it is: CVE-2025-27517 is a critical code injection vulnerability in livewire volt, published on 5 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-27517 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- livewire/volt (Packagist): affected all versions; fixed in 1.7.0\n- livewire/volt (Packagist): affected all versions; fixed in 1.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-27517/ (Markdown: https://insights.sbomify.com/CVE-2025-27517/index.md)","id":"CVE-2025-27517","markdown":"https://insights.sbomify.com/CVE-2025-27517/index.md","name":"CVE-2025-27517","record":{"aliases":["GHSA-v69f-5jxm-hwvv"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Livewire Volt library","requires_auth":"none","summary":"Attackers can achieve remote code execution by sending malicious request payloads to Volt components, requiring an upgrade to the latest version.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Volt is an elegantly crafted functional API for Livewire. Malicious, user-crafted request payloads could potentially lead to remote code execution within Volt components. This vulnerability is fixed in 1.7.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Volt Allows RCE Via User-Crafted Requests","id":"CVE-2025-27517","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Cognita CORS misconfiguration in backend API server","id":"CVE-2025-27518"},"packages":[{"ecosystem":"Packagist","fixed":["1.7.0"],"introduced":["0"],"last_affected":[],"package":"livewire/volt","purl":null,"source":"GHSA-v69f-5jxm-hwvv"},{"ecosystem":"Packagist","fixed":["1.7.0"],"introduced":["0"],"last_affected":[],"package":"livewire/volt","purl":"pkg:composer/livewire/volt","source":"GHSA-v69f-5jxm-hwvv"}],"prev":{"headline":"Jinja sandbox breakout through attr filter selecting format method","id":"CVE-2025-27516"},"products":["volt"],"published":"2025-03-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-05","vendors":["livewire"]},"summary":"Attackers can achieve remote code execution by sending malicious request payloads to Volt components, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/CVE-2025-27517/"}