# CVE-2025-27517: Volt Allows RCE Via User-Crafted Requests

> Attackers can achieve remote code execution by sending malicious request payloads to Volt components, requiring an upgrade to the latest version.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2025
- **Updated:** 5 Mar 2025
- **Also known as:** GHSA-v69f-5jxm-hwvv

## What is CVE-2025-27517?

CVE-2025-27517 is a critical code injection vulnerability in livewire volt, published on 5 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Volt is an elegantly crafted functional API for Livewire. Malicious, user-crafted request payloads could potentially lead to remote code execution within Volt components. This vulnerability is fixed in 1.7.0.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-27517?

2 open source packages ship an affected version, including livewire/volt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `livewire/volt` | Packagist | All versions | 1.7.0 |
| `livewire/volt` | Packagist | All versions | 1.7.0 |

## How do I fix CVE-2025-27517?

Upgrade livewire/volt to 1.7.0 or later.

## Is CVE-2025-27517 being exploited?

There is no known exploitation of CVE-2025-27517 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27517 and fix it if it is affected.

What it is: CVE-2025-27517 is a critical code injection vulnerability in livewire volt, published on 5 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27517 in the wild and no public exploit code.

Affected packages and fixed versions:
- livewire/volt (Packagist): affected all versions; fixed in 1.7.0
- livewire/volt (Packagist): affected all versions; fixed in 1.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27517/ (Markdown: https://insights.sbomify.com/CVE-2025-27517/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27517
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27517
- OSV: https://osv.dev/vulnerability/CVE-2025-27517

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27517/
Summaries are generated and may contain mistakes; the official description above is the record.
