# CVE-2025-27520: BentoML Allows Remote Code Execution (RCE) via Insecure Deserialization

> Unauthenticated attackers can execute arbitrary code on servers using BentoML due to insecure deserialization in the serde module.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Apr 2025
- **Updated:** 4 Apr 2025
- **Also known as:** GHSA-33xw-247w-6hmc, PYSEC-2026-294

## What is CVE-2025-27520?

CVE-2025-27520 is a critical unsafe deserialization vulnerability in BentoML, published on 4 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

BentoML is a Python library for building online serving systems optimized for AI apps and model inference. A Remote Code Execution (RCE) vulnerability caused by insecure deserialization has been identified in the latest version (v1.4.2) of BentoML. It allows any unauthenticated user to execute arbitrary code on the server. It exists an unsafe code segment in serde.py. This vulnerability is fixed in 1.4.3.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-27520?

3 open source packages ship an affected version, including bentoml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bentoml` | PyPI | From 1.3.4 | 1.4.3 |
| `bentoml` | PyPI | From 1.3.4 | 1.4.3 |
| `bentoml` | PyPI | From 1.3.4 | 1.4.3 |

Products: Bentoml Bentoml.

## How do I fix CVE-2025-27520?

Upgrade bentoml to 1.4.3 or later.

## Is CVE-2025-27520 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27520 exists.

Public exploit code:

- BentoML RCE (metasploit)
- ay 09 — CVE-2025-27520 (BentoML-style insecure deserialization) — Local Docker lab (github_poc): https://github.com/amalpvatayam67/day09-bentoml-deser-lab
- https://github.com/Evillm/CVE-2025-27520-PoC (github_poc): https://github.com/Evillm/CVE-2025-27520-PoC
- exploit for CVE-2025-27520 A Remote Code Execution (RCE) vulnerability caused by insecure deserialization  in the latest version (v1.4.2) of BentoML. It allows any unauthenticated user to execute arbitrary code on the server. It exists an unsafe code segment in serde.py. This vulnerability is fixed in 1.4.3. (github_poc): https://github.com/electricsheep08/CVE-2025-27520

## Other vulnerabilities in BentoML

- [CVE-2025-54381](https://insights.sbomify.com/CVE-2025-54381/): BentoML is Vulnerable to an SSRF Attack Through File Upload Processing (critical 9.9)
- [CVE-2025-32375](https://insights.sbomify.com/CVE-2025-32375/): Insecure Deserialization leads to RCE in BentoML's runner server (critical 9.8)
- [CVE-2026-44345](https://insights.sbomify.com/CVE-2026-44345/): BentoML: Dockerfile command injection via docker.base_image (high 8.8)
- [CVE-2026-44346](https://insights.sbomify.com/CVE-2026-44346/): BentoML: Dockerfile command injection via envs[*].name in bentofile.yaml (high 8.8)
- [CVE-2026-35044](https://insights.sbomify.com/CVE-2026-35044/): BentoML has a Server-Side Template Injection via unsandboxed Jinja2 Environment in Dockerfile generation (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27520 and fix it if it is affected.

What it is: CVE-2025-27520 is a critical unsafe deserialization vulnerability in BentoML, published on 4 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27520 exists.

Affected packages and fixed versions:
- bentoml (PyPI): affected from 1.3.4; fixed in 1.4.3
- bentoml (PyPI): affected from 1.3.4; fixed in 1.4.3
- bentoml (PyPI): affected from 1.3.4; fixed in 1.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27520/ (Markdown: https://insights.sbomify.com/CVE-2025-27520/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27520
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27520
- OSV: https://osv.dev/vulnerability/CVE-2025-27520

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27520/
Summaries are generated and may contain mistakes; the official description above is the record.
