CVE-2025-27522 Apache InLong: JDBC Vulnerability during verification processing

Medium 6.5 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2025-27522?

CVE-2025-27522 is a medium-severity vulnerability in Apache InLong, published on 28 May 2025.

Official description

Deserialization of Untrusted Data vulnerability in Apache InLong.

This issue affects Apache InLong: from 1.13.0 through 2.1.0. This vulnerability is a secondary mining bypass for CVE-2024-26579. Users are advised to upgrade to Apache InLong's 2.2.0 or cherry-pick [1] to solve it.

[1]

https://github.com/apache/inlong/pull/11732

Weakness: CWE-502

Which versions are affected by CVE-2025-27522?

2 open source packages ship an affected version, including org.apache.inlong:manager-pojo. It affects 1 product.

PackageAffectedFixed in
org.apache.inlong:manager-pojo MavenFrom 1.13.02.2.0
org.apache.inlong:manager-pojo MavenFrom 1.13.02.2.0

Products include Apache Inlong.

How do I fix CVE-2025-27522?

Upgrade org.apache.inlong:manager-pojo to 2.2.0 or later.

Is CVE-2025-27522 being exploited?

There is no known exploitation of CVE-2025-27522 in the wild and no public exploit code.

Sources

Also known as GHSA-r324-vgr5-73c9.

Is CVE-2025-27522 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free