CVE-2025-27531 Apache InLong: An arbitrary file read vulnerability for JDBC

Critical 9.8 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2025-27531?

CVE-2025-27531 is a critical vulnerability in Apache InLong, published on 6 Jun 2025.

Official description

Deserialization of Untrusted Data vulnerability in Apache InLong. 

This issue affects Apache InLong: from 1.13.0 before 2.1.0,

this issue would allow an authenticated attacker to read arbitrary files by double writing the param.

Users are recommended to upgrade to version 2.1.0, which fixes the issue.

Weakness: CWE-502

Which versions are affected by CVE-2025-27531?

2 open source packages ship an affected version, including org.apache.inlong:inlong-manager. It affects 1 product.

PackageAffectedFixed in
org.apache.inlong:inlong-manager MavenFrom 1.13.02.1.0
org.apache.inlong:inlong-manager MavenFrom 1.13.02.1.0

Products include Apache Inlong.

How do I fix CVE-2025-27531?

Upgrade org.apache.inlong:inlong-manager to 2.1.0 or later.

Is CVE-2025-27531 being exploited?

There is no known exploitation of CVE-2025-27531 in the wild and no public exploit code.

Sources

Also known as GHSA-62gc-8jr5-x9pm.

Is CVE-2025-27531 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free