CVE-2025-27533 Apache ActiveMQ: Unchecked buffer length can cause excessive memory allocation
Attackers can cause denial of service in Apache ActiveMQ by triggering excessive memory allocation during unmarshalling, requiring mitigation via upgrade or mutual TLS.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-27533?
CVE-2025-27533 is a medium-severity denial of service vulnerability in Apache Activemq, published on 7 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Memory Allocation with Excessive Size Value vulnerability in Apache ActiveMQ.
During unmarshalling of OpenWire commands the size value of buffers was not properly validated which could lead to excessive memory allocation and be exploited to cause a denial of service (DoS) by depleting process memory, thereby affecting applications and services that rely on the availability of the ActiveMQ broker when not using mutual TLS connections. This issue affects Apache ActiveMQ: from 6.0.0 before 6.1.6, from 5.18.0 before 5.18.7, from 5.17.0 before 5.17.7, before 5.16.8. ActiveMQ 5.19.0 is not affected.
Users are recommended to upgrade to version 6.1.6+, 5.19.0+, 5.18.7+, 5.17.7, or 5.16.8 or which fixes the issue.
Existing users may implement mutual TLS to mitigate the risk on affected brokers.
Weakness: CWE-789
Which versions are affected by CVE-2025-27533?
17 open source packages ship an affected version, including org.apache.activemq:activemq-client, activemq and org.apache.activemq:activemq-openwire-legacy. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.activemq:activemq-client Maven | All versions | 5.16.8 |
org.apache.activemq:activemq-client Maven | All versions | 5.16.8 |
org.apache.activemq:activemq-client Maven | From 5.17.0 | 5.17.7 |
org.apache.activemq:activemq-client Maven | From 5.17.0 | 5.17.7 |
org.apache.activemq:activemq-client Maven | From 5.18.0 | 5.18.7 |
org.apache.activemq:activemq-client Maven | From 5.18.0 | 5.18.7 |
11 more packages
org.apache.activemq:activemq-client Maven | From 6.0.0 | 6.1.6 |
org.apache.activemq:activemq-client Maven | From 6.0.0 | 6.1.6 |
activemq Bitnami | From 5.16.0 | 5.16.8, 5.17.7, 5.18.7, 6.1.6 |
org.apache.activemq:activemq-openwire-legacy Maven | All versions | 5.16.8 |
org.apache.activemq:activemq-openwire-legacy Maven | All versions | 5.16.8 |
org.apache.activemq:activemq-openwire-legacy Maven | From 5.17.0 | 5.17.7 |
org.apache.activemq:activemq-openwire-legacy Maven | From 5.17.0 | 5.17.7 |
org.apache.activemq:activemq-openwire-legacy Maven | From 5.18.0 | 5.18.7 |
org.apache.activemq:activemq-openwire-legacy Maven | From 5.18.0 | 5.18.7 |
org.apache.activemq:activemq-openwire-legacy Maven | From 6.0.0 | 6.1.6 |
org.apache.activemq:activemq-openwire-legacy Maven | From 6.0.0 | 6.1.6 |
Products include Apache Activemq.
How do I fix CVE-2025-27533?
Upgrade org.apache.activemq:activemq-client to a fixed version for your release line: 5.16.8, 5.17.7, 5.18.7 or 6.1.6.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-27533 being exploited?
There is no known exploitation of CVE-2025-27533 in the wild and no public exploit code.
Public exploit code: 1 Exploit-DB entry and 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Activemq
Sources
Also known as BIT-activemq-2025-27533, DEBIAN-CVE-2025-27533, DLA-4222-1, GHSA-whxr-3p84-rf3c, OESA-2025-1507, ROOT-APP-MAVEN-CVE-2025-27533 and 1 more.