# CVE-2025-27533: Apache ActiveMQ: Unchecked buffer length can cause excessive memory allocation

> Attackers can cause denial of service in Apache ActiveMQ by triggering excessive memory allocation during unmarshalling, requiring mitigation via upgrade or mutual TLS.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H/AU:Y/R:A/V:D/RE:M/U:Red`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2025
- **Updated:** 3 Nov 2025
- **Also known as:** BIT-activemq-2025-27533, DEBIAN-CVE-2025-27533, DLA-4222-1, GHSA-whxr-3p84-rf3c, OESA-2025-1507, ROOT-APP-MAVEN-CVE-2025-27533, UBUNTU-CVE-2025-27533

## What is CVE-2025-27533?

CVE-2025-27533 is a medium-severity denial of service vulnerability in Apache Activemq, published on 7 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Memory Allocation with Excessive Size Value vulnerability in Apache ActiveMQ.

During unmarshalling of OpenWire commands the size value of buffers was not properly validated which could lead to excessive memory allocation and be exploited to cause a denial of service (DoS) by depleting process memory, thereby affecting applications and services that rely on the availability of the ActiveMQ broker when not using mutual TLS connections.
This issue affects Apache ActiveMQ: from 6.0.0 before 6.1.6, from 5.18.0 before 5.18.7, from 5.17.0 before 5.17.7, before 5.16.8. ActiveMQ 5.19.0 is not affected.

Users are recommended to upgrade to version 6.1.6+, 5.19.0+,  5.18.7+, 5.17.7, or 5.16.8 or which fixes the issue.

Existing users may implement mutual TLS to mitigate the risk on affected brokers.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2025-27533?

17 open source packages ship an affected version, including org.apache.activemq:activemq-client, activemq and org.apache.activemq:activemq-openwire-legacy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-client` | Maven | All versions | 5.16.8 |
| `org.apache.activemq:activemq-client` | Maven | All versions | 5.16.8 |
| `org.apache.activemq:activemq-client` | Maven | From 5.17.0 | 5.17.7 |
| `org.apache.activemq:activemq-client` | Maven | From 5.17.0 | 5.17.7 |
| `org.apache.activemq:activemq-client` | Maven | From 5.18.0 | 5.18.7 |
| `org.apache.activemq:activemq-client` | Maven | From 5.18.0 | 5.18.7 |
| `org.apache.activemq:activemq-client` | Maven | From 6.0.0 | 6.1.6 |
| `org.apache.activemq:activemq-client` | Maven | From 6.0.0 | 6.1.6 |
| `activemq` | Bitnami | From 5.16.0 | 5.16.8, 5.17.7, 5.18.7, 6.1.6 |
| `org.apache.activemq:activemq-openwire-legacy` | Maven | All versions | 5.16.8 |
| `org.apache.activemq:activemq-openwire-legacy` | Maven | All versions | 5.16.8 |
| `org.apache.activemq:activemq-openwire-legacy` | Maven | From 5.17.0 | 5.17.7 |
| `org.apache.activemq:activemq-openwire-legacy` | Maven | From 5.17.0 | 5.17.7 |
| `org.apache.activemq:activemq-openwire-legacy` | Maven | From 5.18.0 | 5.18.7 |
| `org.apache.activemq:activemq-openwire-legacy` | Maven | From 5.18.0 | 5.18.7 |
| `org.apache.activemq:activemq-openwire-legacy` | Maven | From 6.0.0 | 6.1.6 |
| `org.apache.activemq:activemq-openwire-legacy` | Maven | From 6.0.0 | 6.1.6 |

Products: Apache Activemq.

## How do I fix CVE-2025-27533?

Upgrade org.apache.activemq:activemq-client to a fixed version for your release line: 5.16.8, 5.17.7, 5.18.7 or 6.1.6.

## Is CVE-2025-27533 being exploited?

There is no known exploitation of CVE-2025-27533 in the wild and no public exploit code.

Public exploit code:

- exploit for CVE-2025-27533, a Denial of Service (DoS) vulnerability in Apache ActiveMQ (github_poc): https://github.com/absholi7ly/CVE-2025-27533-Exploit-for-Apache-ActiveMQ
- Apache ActiveMQ 6.1.6 - Denial of Service (DOS) (exploitdb)

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27533 and fix it if it is affected.

What it is: CVE-2025-27533 is a medium-severity denial of service vulnerability in Apache Activemq, published on 7 May 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27533 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.activemq:activemq-client (Maven): affected all versions; fixed in 5.16.8
- org.apache.activemq:activemq-client (Maven): affected all versions; fixed in 5.16.8
- org.apache.activemq:activemq-client (Maven): affected from 5.17.0; fixed in 5.17.7
- org.apache.activemq:activemq-client (Maven): affected from 5.17.0; fixed in 5.17.7
- org.apache.activemq:activemq-client (Maven): affected from 5.18.0; fixed in 5.18.7
- org.apache.activemq:activemq-client (Maven): affected from 5.18.0; fixed in 5.18.7
- org.apache.activemq:activemq-client (Maven): affected from 6.0.0; fixed in 6.1.6
- org.apache.activemq:activemq-client (Maven): affected from 6.0.0; fixed in 6.1.6
- activemq (Bitnami): affected from 5.16.0; fixed in 5.16.8, 5.17.7, 5.18.7, 6.1.6
- org.apache.activemq:activemq-openwire-legacy (Maven): affected all versions; fixed in 5.16.8
- org.apache.activemq:activemq-openwire-legacy (Maven): affected all versions; fixed in 5.16.8
- org.apache.activemq:activemq-openwire-legacy (Maven): affected from 5.17.0; fixed in 5.17.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27533/ (Markdown: https://insights.sbomify.com/CVE-2025-27533/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27533
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27533
- OSV: https://osv.dev/vulnerability/CVE-2025-27533

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27533/
Summaries are generated and may contain mistakes; the official description above is the record.
