CVE-2025-27538 MFA Enforcement Bypass Allows Unauthorized Removal of MFA for Other Users
Attackers with edit permissions can bypass MFA enforcement to disable multi-factor authentication for other users, potentially leading to account takeover.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-27538?
CVE-2025-27538 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 16 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Mattermost versions 10.5.x <= 10.5.1, 9.11.x <= 9.11.9 fail to enforce MFA checks in PUT /api/v4/users/user-id/mfa when the requesting user differs from the target user ID, which allows users with edit_other_users permission to activate or deactivate MFA for other users, even if those users have not set up MFA.
Weakness: CWE-306
Which versions are affected by CVE-2025-27538?
10 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250314142426-c049748b8863 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250314142426-c049748b8863 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250314142426-c049748b8863 |
github.com/mattermost/mattermost/server/v8 Go | From 10.5.0 | 10.5.2 |
github.com/mattermost/mattermost/server/v8 Go | From 10.5.0 | 10.5.2 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.10 |
4 more packages
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.10 |
github.com/mattermost/mattermost-server Go | From 9.11.0+incompatible | 9.11.10+incompatible, 10.5.2+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-27538?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250314142426-c049748b8863, 10.5.2 or 9.11.10.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-27538 being exploited?
There is no known exploitation of CVE-2025-27538 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-j5jw-m2ph-3jjf, GO-2025-3620.