# CVE-2025-27538: MFA Enforcement Bypass Allows Unauthorized Removal of MFA for Other Users

> Attackers with edit permissions can bypass MFA enforcement to disable multi-factor authentication for other users, potentially leading to account takeover.

- **Severity:** Low 2.2 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Apr 2025
- **Updated:** 16 Apr 2025
- **Also known as:** GHSA-j5jw-m2ph-3jjf, GO-2025-3620

## What is CVE-2025-27538?

CVE-2025-27538 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 16 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Mattermost versions 10.5.x <= 10.5.1, 9.11.x <= 9.11.9 fail to enforce MFA checks in PUT /api/v4/users/user-id/mfa when the requesting user differs from the target user ID, which allows users with edit_other_users permission to activate or deactivate MFA for other users, even if those users have not set up MFA.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2025-27538?

10 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250314142426-c049748b8863 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250314142426-c049748b8863 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250314142426-c049748b8863 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.5.0 | 10.5.2 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.5.0 | 10.5.2 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.11.0 | 9.11.10 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.11.0 | 9.11.10 |
| `github.com/mattermost/mattermost-server` | Go | From 9.11.0+incompatible | 9.11.10+incompatible, 10.5.2+incompatible |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-27538?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250314142426-c049748b8863, 10.5.2 or 9.11.10.

## Is CVE-2025-27538 being exploited?

There is no known exploitation of CVE-2025-27538 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27538 and fix it if it is affected.

What it is: CVE-2025-27538 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 16 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27538 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250314142426-c049748b8863
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250314142426-c049748b8863
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250314142426-c049748b8863
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.5.0; fixed in 10.5.2
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.5.0; fixed in 10.5.2
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.11.0; fixed in 9.11.10
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.11.0; fixed in 9.11.10
- github.com/mattermost/mattermost-server (Go): affected from 9.11.0+incompatible; fixed in 9.11.10+incompatible, 10.5.2+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27538/ (Markdown: https://insights.sbomify.com/CVE-2025-27538/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27538
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27538
- OSV: https://osv.dev/vulnerability/CVE-2025-27538

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27538/
Summaries are generated and may contain mistakes; the official description above is the record.
