# CVE-2025-27553: Apache Commons VFS: Possible path traversal issue when using NameScope.DESCENDENT

> Attackers can bypass path restrictions in Apache Commons VFS using encoded traversal sequences, potentially accessing or modifying files outside the intended directory.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Mar 2025
- **Updated:** 2 Apr 2025
- **Also known as:** CLSA-2026-1784164089, DEBIAN-CVE-2025-27553, DLA-4111-1, GHSA-9q4x-fr4m-jp86, OESA-2025-1940, OESA-2025-1941, OESA-2025-1942, RHSA-2025:10548, UBUNTU-CVE-2025-27553

## What is CVE-2025-27553?

CVE-2025-27553 is a high-severity path traversal vulnerability in Apache Commons VFS, published on 23 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Relative Path Traversal vulnerability in Apache Commons VFS before 2.10.0.

The FileObject API in Commons VFS has a 'resolveFile' method that
takes a 'scope' parameter. Specifying 'NameScope.DESCENDENT' promises that "an exception is thrown if the resolved file is not a descendent of
the base file". However, when the path contains encoded ".."
characters (for example, "%2E%2E/bar.txt"), it might return file objects that are not
a descendent of the base file, without throwing an exception.
This issue affects Apache Commons VFS: before 2.10.0.

Users are recommended to upgrade to version 2.10.0, which fixes the issue.

Weakness: CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2025-27553?

2 open source packages ship an affected version, including org.apache.commons:commons-vfs2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.commons:commons-vfs2` | Maven | All versions | 2.10.0 |
| `org.apache.commons:commons-vfs2` | Maven | All versions | 2.10.0 |
| `apache-commons-vfs` | Red Hat:rhel_els:7 | All versions | 0:2.0-11.el7_9.1 |
| `apache-commons-vfs-ant` | Red Hat:rhel_els:7 | All versions | 0:2.0-11.el7_9.1 |
| `apache-commons-vfs-examples` | Red Hat:rhel_els:7 | All versions | 0:2.0-11.el7_9.1 |
| `apache-commons-vfs-javadoc` | Red Hat:rhel_els:7 | All versions | 0:2.0-11.el7_9.1 |

Products: Apache Commons Vfs.

## How do I fix CVE-2025-27553?

Upgrade org.apache.commons:commons-vfs2 to 2.10.0 or later.

## Is CVE-2025-27553 being exploited?

There is no known exploitation of CVE-2025-27553 in the wild and no public exploit code.

## Other vulnerabilities in Apache Commons VFS

- [CVE-2025-30474](https://insights.sbomify.com/CVE-2025-30474/): Apache Commons VFS: Failing to find an FTP file can reveal the URI's password in an error message (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27553 and fix it if it is affected.

What it is: CVE-2025-27553 is a high-severity path traversal vulnerability in Apache Commons VFS, published on 23 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27553 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.commons:commons-vfs2 (Maven): affected all versions; fixed in 2.10.0
- org.apache.commons:commons-vfs2 (Maven): affected all versions; fixed in 2.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27553/ (Markdown: https://insights.sbomify.com/CVE-2025-27553/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27553
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27553
- OSV: https://osv.dev/vulnerability/CVE-2025-27553

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27553/
Summaries are generated and may contain mistakes; the official description above is the record.
