# CVE-2025-27556: Django Potential Denial of Service (DoS) on Windows

> Attackers can cause denial of service in Django applications on Windows by sending inputs with many Unicode characters, exploiting slow NFKC normalization.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2025
- **Updated:** 2 Apr 2025
- **Also known as:** BIT-django-2025-27556, GHSA-wqfg-m96j-85vm, PYSEC-2025-14, openSUSE-SU-2025:14986-1

## What is CVE-2025-27556?

CVE-2025-27556 is a medium-severity denial of service vulnerability in Djangoproject Django, published on 2 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Django 5.1 before 5.1.8 and 5.0 before 5.0.14. The NFKC normalization is slow on Windows. As a consequence, django.contrib.auth.views.LoginView, django.contrib.auth.views.LogoutView, and django.views.i18n.set_language are subject to a potential denial-of-service attack via certain inputs with a very large number of Unicode characters.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-27556?

6 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 5.0.0 | 5.0.14, 5.1.8 |
| `django` | PyPI | From 5.0 | 5.0.14 |
| `django` | PyPI | From 5.1 | 5.1.8, 5.0.14 |
| `django` | PyPI | From 5.1 | 5.1.8 |
| `Django` | PyPI | From 5.0 | 5.0.14 |
| `Django` | PyPI | From 5.1 | 5.1.8 |
| `python-Django` | openSUSE:Tumbleweed | All versions | 5.1.8-1.1 |

Products: Djangoproject Django.

## How do I fix CVE-2025-27556?

Upgrade django to a fixed version for your release line: 5.0.14 or 5.1.8.

## Is CVE-2025-27556 being exploited?

There is no known exploitation of CVE-2025-27556 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27556 and fix it if it is affected.

What it is: CVE-2025-27556 is a medium-severity denial of service vulnerability in Djangoproject Django, published on 2 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27556 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 5.0.0; fixed in 5.0.14, 5.1.8
- django (PyPI): affected from 5.0; fixed in 5.0.14
- django (PyPI): affected from 5.1; fixed in 5.1.8, 5.0.14
- django (PyPI): affected from 5.1; fixed in 5.1.8
- Django (PyPI): affected from 5.0; fixed in 5.0.14
- Django (PyPI): affected from 5.1; fixed in 5.1.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27556/ (Markdown: https://insights.sbomify.com/CVE-2025-27556/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27556
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27556
- OSV: https://osv.dev/vulnerability/CVE-2025-27556

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27556/
Summaries are generated and may contain mistakes; the official description above is the record.
