CVE-2025-27571 Channel metadata visible in archived channels despite configuration setting

Medium 4.3 Published Updated

Authenticated users can view metadata of archived channels despite configuration settings restricting access, leading to unauthorized information disclosure.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-27571?

CVE-2025-27571 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 16 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Mattermost versions 10.5.x <= 10.5.1, 10.4.x <= 10.4.3, 9.11.x <= 9.11.9 fail to check the "Allow Users to View Archived Channels" configuration when fetching channel metadata of a post from archived channels, which allows authenticated users to access such information when a channel is archived.

Weakness: CWE-863

Which versions are affected by CVE-2025-27571?

12 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250218121836-2b5275d87136
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250314142426-c049748b8863
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250314142426-c049748b8863
github.com/mattermost/mattermost/server/v8 GoFrom 10.4.010.4.4
github.com/mattermost/mattermost/server/v8 GoFrom 10.4.010.4.4
github.com/mattermost/mattermost/server/v8 GoFrom 10.5.010.5.2
6 more packages
github.com/mattermost/mattermost/server/v8 GoFrom 10.5.010.5.2
github.com/mattermost/mattermost/server/v8 GoFrom 9.11.09.11.10
github.com/mattermost/mattermost/server/v8 GoFrom 9.11.09.11.10
github.com/mattermost/mattermost-server GoFrom 9.11.0+incompatible9.11.10+incompatible, 10.4.4+incompatible, 10.5.2+incompatible
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone

Products include Mattermost Mattermost Server.

How do I fix CVE-2025-27571?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250218121836-2b5275d87136, 8.0.0-20250314142426-c049748b8863, 10.4.4 or 10.5.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-27571 being exploited?

There is no known exploitation of CVE-2025-27571 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-h4rr-f37j-4hh7, GO-2025-3619.

Is CVE-2025-27571 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free