# CVE-2025-27590: Oxidized Web RANCID migration page allows unauthenticated user to gain control over Linux user account

> Unauthenticated attackers can exploit a path traversal flaw in the RANCID migration page to execute code and take over the underlying Linux account.

- **Severity:** Critical 9.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Mar 2025
- **Updated:** 4 Mar 2025
- **Also known as:** GHSA-jx6p-9c26-g373

## What is CVE-2025-27590?

CVE-2025-27590 is a critical path traversal vulnerability in Oxidized Web, published on 3 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In oxidized-web (aka Oxidized Web) before 0.15.0, the RANCID migration page allows an unauthenticated user to gain control over the Linux user account that is running oxidized-web.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-27590?

2 open source packages ship an affected version, including oxidized-web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `oxidized-web` | RubyGems | All versions | 0.15.0 |
| `oxidized-web` | RubyGems | All versions | 0.15.0 |

Products: Oxidized Web Project Oxidized Web.

## How do I fix CVE-2025-27590?

Upgrade oxidized-web to 0.15.0 or later.

## Is CVE-2025-27590 being exploited?

There is no known exploitation of CVE-2025-27590 in the wild and no public exploit code.

Public exploit code:

- https://github.com/fatkz/CVE-2025-27590 (github_poc): https://github.com/fatkz/CVE-2025-27590

## Other vulnerabilities in Oxidized Web

- [CVE-2019-25088](https://insights.sbomify.com/CVE-2019-25088/): ytti Oxidized Web conf_search.haml cross site scripting (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27590 and fix it if it is affected.

What it is: CVE-2025-27590 is a critical path traversal vulnerability in Oxidized Web, published on 3 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27590 in the wild and no public exploit code.

Affected packages and fixed versions:
- oxidized-web (RubyGems): affected all versions; fixed in 0.15.0
- oxidized-web (RubyGems): affected all versions; fixed in 0.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27590/ (Markdown: https://insights.sbomify.com/CVE-2025-27590/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27590
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27590
- OSV: https://osv.dev/vulnerability/CVE-2025-27590

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27590/
Summaries are generated and may contain mistakes; the official description above is the record.
