{"answers":{"affected":"3 open source packages ship an affected version, including below. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-27591 in the wild and no public exploit code.","fix":"Upgrade below to 0.9.0 or later.","what":"CVE-2025-27591 is a medium-severity vulnerability in Meta Platforms, Inc below, published on 11 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-27591 and fix it if it is affected.\n\nWhat it is: CVE-2025-27591 is a medium-severity vulnerability in Meta Platforms, Inc below, published on 11 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-27591 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- below (crates.io): affected all versions; fixed in 0.9.0\n- below (crates.io): affected all versions; fixed in 0.9.0\n- below (crates.io): affected from 0.0.0-0; fixed in 0.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-27591/ (Markdown: https://insights.sbomify.com/CVE-2025-27591/index.md)","id":"CVE-2025-27591","markdown":"https://insights.sbomify.com/CVE-2025-27591/index.md","name":"CVE-2025-27591","record":{"aliases":["GHSA-9mc5-7qhg-fp3w","RUSTSEC-2025-0149","openSUSE-SU-2026:10194-1"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Linux system monitoring tool","requires_auth":"none","summary":"Local unprivileged users can escalate to root privileges via symlink attacks on a world-writable log directory in the Below service.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"facebook","cpe":[{"product":"below","vendor":"facebook"}],"cvss":{"score":6.8,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-732","name":"Incorrect Permission Assignment for Critical Resource"}],"description":"A privilege escalation vulnerability existed in the Below service prior to v0.9.0 due to the creation of a world-writable directory at /var/log/below. This could have allowed local unprivileged users to escalate to root privileges through symlink attacks that manipulate files such as /etc/shadow.","ecosystems":["crates.io","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":"2025-07-12","github_poc":19,"max_poc_stars":33,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-07-13T08:41:06Z","kind":"github_poc","ref":"https://github.com/BridgerAlderson/CVE-2025-27591-PoC","stars":33,"title":"CVE-2025-27591 is a privilege escalation vulnerability that affected the Below service before version 0.9.0"},{"date":"2025-11-19T19:56:14Z","kind":"github_poc","ref":"https://github.com/0x00Jeff/CVE-2025-27591","stars":15,"title":"self cleaning CVE-2025-27591 Poc that grants a root reverse shell instead of modifying passwd files"},{"date":"2025-07-12T21:17:40Z","kind":"github_poc","ref":"https://github.com/obamalaolu/CVE-2025-27591","stars":13,"title":"CVE-2025-27591"},{"date":"2025-07-15T05:48:00Z","kind":"github_poc","ref":"https://github.com/dollarboysushil/Linux-Privilege-Escalation-CVE-2025-27591","stars":7,"title":"CVE-2025-27591 is a known privilege escalation vulnerability in the Below service (version \u003c v0.9.0)"},{"date":"2025-07-18T03:26:31Z","kind":"github_poc","ref":"https://github.com/incommatose/CVE-2025-27591-PoC","stars":5,"title":"A Proof of Concept for CVE-2025-27591, a local privilege escalation in Below \u003c v0.9.0"},{"date":"2025-07-12T22:50:59Z","kind":"github_poc","ref":"https://github.com/rvzsec/CVE-2025-27591","stars":3,"title":"Below v0.8.1 - Local Privilege Escalation (CVE-2025-27591) - PoC Exploit"},{"date":"2025-07-31T12:22:20Z","kind":"github_poc","ref":"https://github.com/Cythonic1/CVE-2025-27591","stars":3,"title":"a C exploit for CVE-2025-27591, which allow an attacker to escalate privilege to root."},{"date":"2025-07-19T22:17:47Z","kind":"github_poc","ref":"https://github.com/00xCanelo/CVE-2025-27591","stars":2,"title":"🔥 Local Privilege Escalation Exploit for CVE-2025-27591 | Abuses world-writable log dir in Below to gain root via /etc/passwd injection"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Below has Incorrect Permission Assignment for Critical Resource","id":"CVE-2025-27591","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"privilege_escalation","year":"2025"},"n_packages":4,"n_references":2,"next":{"headline":"RCE due to Device Driver","id":"CVE-2025-27593"},"packages":[{"ecosystem":"crates.io","fixed":["0.9.0"],"introduced":["0"],"last_affected":[],"package":"below","purl":null,"source":"GHSA-9mc5-7qhg-fp3w"},{"ecosystem":"crates.io","fixed":["0.9.0"],"introduced":["0"],"last_affected":[],"package":"below","purl":"pkg:cargo/below","source":"GHSA-9mc5-7qhg-fp3w"},{"ecosystem":"crates.io","fixed":["0.9.0"],"introduced":["0.0.0-0"],"last_affected":[],"package":"below","purl":"pkg:cargo/below","source":"RUSTSEC-2025-0149"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["20260213-1.1"],"introduced":["0"],"last_affected":[],"package":"cargo-audit-advisory-db","purl":"pkg:rpm/opensuse/cargo-audit-advisory-db\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10194-1"}],"prev":{"headline":"Oxidized Web RANCID migration page allows unauthenticated user to gain control over Linux user account","id":"CVE-2025-27590"},"products":["below"],"published":"2025-03-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-21","vendors":["Meta Platforms, Inc"]},"summary":"Local unprivileged users can escalate to root privileges via symlink attacks on a world-writable log directory in the Below service.","url":"https://insights.sbomify.com/CVE-2025-27591/"}