# CVE-2025-27591: Below has Incorrect Permission Assignment for Critical Resource

> Local unprivileged users can escalate to root privileges via symlink attacks on a world-writable log directory in the Below service.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2025
- **Updated:** 21 Mar 2025
- **Also known as:** GHSA-9mc5-7qhg-fp3w, RUSTSEC-2025-0149, openSUSE-SU-2026:10194-1

## What is CVE-2025-27591?

CVE-2025-27591 is a medium-severity vulnerability in Meta Platforms, Inc below, published on 11 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A privilege escalation vulnerability existed in the Below service prior to v0.9.0 due to the creation of a world-writable directory at /var/log/below. This could have allowed local unprivileged users to escalate to root privileges through symlink attacks that manipulate files such as /etc/shadow.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2025-27591?

3 open source packages ship an affected version, including below. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `below` | crates.io | All versions | 0.9.0 |
| `below` | crates.io | All versions | 0.9.0 |
| `below` | crates.io | From 0.0.0-0 | 0.9.0 |
| `cargo-audit-advisory-db` | openSUSE:Tumbleweed | All versions | 20260213-1.1 |

Products: Facebook Below.

## How do I fix CVE-2025-27591?

Upgrade below to 0.9.0 or later.

## Is CVE-2025-27591 being exploited?

There is no known exploitation of CVE-2025-27591 in the wild and no public exploit code.

Public exploit code:

- CVE-2025-27591 is a privilege escalation vulnerability that affected the Below service before version 0.9.0 (github_poc): https://github.com/BridgerAlderson/CVE-2025-27591-PoC
- self cleaning CVE-2025-27591 Poc that grants a root reverse shell instead of modifying passwd files (github_poc): https://github.com/0x00Jeff/CVE-2025-27591
- CVE-2025-27591 (github_poc): https://github.com/obamalaolu/CVE-2025-27591
- CVE-2025-27591 is a known privilege escalation vulnerability in the Below service (version < v0.9.0) (github_poc): https://github.com/dollarboysushil/Linux-Privilege-Escalation-CVE-2025-27591
- A Proof of Concept for CVE-2025-27591, a local privilege escalation in Below < v0.9.0 (github_poc): https://github.com/incommatose/CVE-2025-27591-PoC
- Below v0.8.1 - Local Privilege Escalation (CVE-2025-27591) - PoC Exploit (github_poc): https://github.com/rvzsec/CVE-2025-27591

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27591 and fix it if it is affected.

What it is: CVE-2025-27591 is a medium-severity vulnerability in Meta Platforms, Inc below, published on 11 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27591 in the wild and no public exploit code.

Affected packages and fixed versions:
- below (crates.io): affected all versions; fixed in 0.9.0
- below (crates.io): affected all versions; fixed in 0.9.0
- below (crates.io): affected from 0.0.0-0; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27591/ (Markdown: https://insights.sbomify.com/CVE-2025-27591/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27591
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27591
- OSV: https://osv.dev/vulnerability/CVE-2025-27591

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27591/
Summaries are generated and may contain mistakes; the official description above is the record.
