# CVE-2025-27601: Umbraco Allows Improper API Access Control to Low-Privilege Users to Data Type Functionality

> Low-privilege users can modify restricted data type settings due to improper API access control in Umbraco CMS.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2025
- **Updated:** 11 Mar 2025
- **Also known as:** GHSA-6ffg-mjg7-585x

## What is CVE-2025-27601?

CVE-2025-27601 is a medium-severity missing authorization vulnerability in Umbraco Umbraco Cms, published on 11 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Umbraco is a free and open source .NET content management system. An improper API access control issue has been identified Umbraco's API management package prior to versions 15.2.3 and 14.3.3, allowing low-privilege, authenticated users to create and update data type information that should be restricted to users with access to the settings section. The issue is patched in versions 15.2.3 and 14.3.3. No known workarounds are available.

Weakness: CWE-863 (Incorrect Authorization), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2025-27601?

4 open source packages ship an affected version, including Umbraco.Cms.Api.Management. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Umbraco.Cms.Api.Management` | NuGet | All versions | 14.3.3 |
| `Umbraco.Cms.Api.Management` | NuGet | All versions | 14.3.3 |
| `Umbraco.Cms.Api.Management` | NuGet | From 15.0.0-rc1 | 15.2.3 |
| `Umbraco.Cms.Api.Management` | NuGet | From 15.0.0-rc1 | 15.2.3 |

Products: Umbraco Umbraco Cms.

## How do I fix CVE-2025-27601?

Upgrade Umbraco.Cms.Api.Management to a fixed version for your release line: 14.3.3 or 15.2.3.

## Is CVE-2025-27601 being exploited?

There is no known exploitation of CVE-2025-27601 in the wild and no public exploit code.

## Other vulnerabilities in Umbraco Umbraco Cms

- [CVE-2025-67288](https://insights.sbomify.com/CVE-2025-67288/): Umbraco CMS has an arbitrary file upload vulnerability (critical 10.0)
- [CVE-2014-10074](https://insights.sbomify.com/CVE-2014-10074/): File upload in n/a (critical 9.8)
- [CVE-2012-1301](https://insights.sbomify.com/CVE-2012-1301/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2012-10054](https://insights.sbomify.com/CVE-2012-10054/): Umbraco CMS < 4.7.1 codeEditorSave.asmx RCE (critical 9.3)
- [CVE-2025-32017](https://insights.sbomify.com/CVE-2025-32017/): Umbraco has a Management API Vulnerability to Path Traversal With Authenticated Users (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27601 and fix it if it is affected.

What it is: CVE-2025-27601 is a medium-severity missing authorization vulnerability in Umbraco Umbraco Cms, published on 11 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27601 in the wild and no public exploit code.

Affected packages and fixed versions:
- Umbraco.Cms.Api.Management (NuGet): affected all versions; fixed in 14.3.3
- Umbraco.Cms.Api.Management (NuGet): affected all versions; fixed in 14.3.3
- Umbraco.Cms.Api.Management (NuGet): affected from 15.0.0-rc1; fixed in 15.2.3
- Umbraco.Cms.Api.Management (NuGet): affected from 15.0.0-rc1; fixed in 15.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27601/ (Markdown: https://insights.sbomify.com/CVE-2025-27601/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27601
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27601
- OSV: https://osv.dev/vulnerability/CVE-2025-27601

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27601/
Summaries are generated and may contain mistakes; the official description above is the record.
