{"answers":{"affected":"2 open source packages ship an affected version, including com.xwiki.confluencepro:application-confluence-migrator-pro-ui.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27603 exists.","fix":"Upgrade com.xwiki.confluencepro:application-confluence-migrator-pro-ui to 1.2.0 or later.","what":"CVE-2025-27603 is a critical code injection vulnerability in xwikisas application-confluence-migrator-pro, published on 7 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-27603 and fix it if it is affected.\n\nWhat it is: CVE-2025-27603 is a critical code injection vulnerability in xwikisas application-confluence-migrator-pro, published on 7 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27603 exists.\n\nAffected packages and fixed versions:\n- com.xwiki.confluencepro:application-confluence-migrator-pro-ui (Maven): affected from 1.0; fixed in 1.2.0\n- com.xwiki.confluencepro:application-confluence-migrator-pro-ui (Maven): affected from 1.0; fixed in 1.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-27603/ (Markdown: https://insights.sbomify.com/CVE-2025-27603/index.md)","id":"CVE-2025-27603","markdown":"https://insights.sbomify.com/CVE-2025-27603/index.md","name":"CVE-2025-27603","record":{"aliases":["GHSA-6qvp-39mm-95v8"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"XWiki Confluence Migrator","requires_auth":"high_privilege","summary":"Attackers without programming rights can execute arbitrary code via unescaped translations in the Confluence Migrator Pro plugin.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-95","name":"Improper Neutralization of Directives in Dynamically Evaluated Code"}],"description":"XWiki Confluence Migrator Pro helps admins to import confluence packages into their XWiki instance. A user that doesn't have programming rights can execute arbitrary code due to an unescaped translation when creating a page using the Migration Page template. This vulnerability is fixed in 1.2.0.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"XWiki Confluence Migrator Pro allows Remote Code Execution via unescaped translations","id":"CVE-2025-27603","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"XWiki Confluence Migrator Pro's homepage is public","id":"CVE-2025-27604"},"packages":[{"ecosystem":"Maven","fixed":["1.2.0"],"introduced":["1.0"],"last_affected":[],"package":"com.xwiki.confluencepro:application-confluence-migrator-pro-ui","purl":null,"source":"GHSA-6qvp-39mm-95v8"},{"ecosystem":"Maven","fixed":["1.2.0"],"introduced":["1.0"],"last_affected":[],"package":"com.xwiki.confluencepro:application-confluence-migrator-pro-ui","purl":"pkg:maven/com.xwiki.confluencepro/application-confluence-migrator-pro-ui","source":"GHSA-6qvp-39mm-95v8"}],"prev":{"headline":"Umbraco Allows a Restricted Editor User to Delete Media Item or Access Unauthorized Content","id":"CVE-2025-27602"},"products":["application-confluence-migrator-pro"],"published":"2025-03-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-07","vendors":["xwikisas"]},"summary":"Attackers without programming rights can execute arbitrary code via unescaped translations in the Confluence Migrator Pro plugin.","url":"https://insights.sbomify.com/CVE-2025-27603/"}