# CVE-2025-27603: XWiki Confluence Migrator Pro allows Remote Code Execution via unescaped translations

> Attackers without programming rights can execute arbitrary code via unescaped translations in the Confluence Migrator Pro plugin.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2025
- **Updated:** 7 Mar 2025
- **Also known as:** GHSA-6qvp-39mm-95v8

## What is CVE-2025-27603?

CVE-2025-27603 is a critical code injection vulnerability in xwikisas application-confluence-migrator-pro, published on 7 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

XWiki Confluence Migrator Pro helps admins to import confluence packages into their XWiki instance. A user that doesn't have programming rights can execute arbitrary code due to an unescaped translation when creating a page using the Migration Page template. This vulnerability is fixed in 1.2.0.

Weakness: CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2025-27603?

2 open source packages ship an affected version, including com.xwiki.confluencepro:application-confluence-migrator-pro-ui.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.xwiki.confluencepro:application-confluence-migrator-pro-ui` | Maven | From 1.0 | 1.2.0 |
| `com.xwiki.confluencepro:application-confluence-migrator-pro-ui` | Maven | From 1.0 | 1.2.0 |

## How do I fix CVE-2025-27603?

Upgrade com.xwiki.confluencepro:application-confluence-migrator-pro-ui to 1.2.0 or later.

## Is CVE-2025-27603 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27603 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27603 and fix it if it is affected.

What it is: CVE-2025-27603 is a critical code injection vulnerability in xwikisas application-confluence-migrator-pro, published on 7 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27603 exists.

Affected packages and fixed versions:
- com.xwiki.confluencepro:application-confluence-migrator-pro-ui (Maven): affected from 1.0; fixed in 1.2.0
- com.xwiki.confluencepro:application-confluence-migrator-pro-ui (Maven): affected from 1.0; fixed in 1.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27603/ (Markdown: https://insights.sbomify.com/CVE-2025-27603/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27603
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27603
- OSV: https://osv.dev/vulnerability/CVE-2025-27603

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27603/
Summaries are generated and may contain mistakes; the official description above is the record.
