# CVE-2025-27604: XWiki Confluence Migrator Pro's homepage is public

> Guest users can access the public homepage to download migration packages, potentially exposing sensitive information.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2025
- **Updated:** 7 Mar 2025
- **Also known as:** GHSA-3w9f-2pph-j5vc

## What is CVE-2025-27604?

CVE-2025-27604 is a high-severity vulnerability in xwikisas application-confluence-migrator-pro, published on 7 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Confluence Migrator Pro helps admins to import confluence packages into their XWiki instance. The homepage of the application is public which enables a guest to download the package which might contain sensitive information. This vulnerability is fixed in 1.11.7.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-27604?

2 open source packages ship an affected version, including com.xwiki.confluencepro:application-confluence-migrator-pro-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.xwiki.confluencepro:application-confluence-migrator-pro-ui` | Maven | All versions | 1.11.7 |
| `com.xwiki.confluencepro:application-confluence-migrator-pro-ui` | Maven | All versions | 1.11.7 |

Products: Xwiki Confluence Migrator.

## How do I fix CVE-2025-27604?

Upgrade com.xwiki.confluencepro:application-confluence-migrator-pro-ui to 1.11.7 or later.

## Is CVE-2025-27604 being exploited?

There is no known exploitation of CVE-2025-27604 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27604 and fix it if it is affected.

What it is: CVE-2025-27604 is a high-severity vulnerability in xwikisas application-confluence-migrator-pro, published on 7 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27604 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.xwiki.confluencepro:application-confluence-migrator-pro-ui (Maven): affected all versions; fixed in 1.11.7
- com.xwiki.confluencepro:application-confluence-migrator-pro-ui (Maven): affected all versions; fixed in 1.11.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27604/ (Markdown: https://insights.sbomify.com/CVE-2025-27604/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27604
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27604
- OSV: https://osv.dev/vulnerability/CVE-2025-27604

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27604/
Summaries are generated and may contain mistakes; the official description above is the record.
