{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-27608 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-27608 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-27608 is a low-severity cross-site scripting vulnerability in arduino-ide, published on 2 Apr 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-27608 and fix it if it is affected.\n\nWhat it is: CVE-2025-27608 is a low-severity cross-site scripting vulnerability in arduino-ide, published on 2 Apr 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-27608 in the wild and no public exploit code.\n\nAffected product: arduino-ide. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-27608/ (Markdown: https://insights.sbomify.com/CVE-2025-27608/index.md)","id":"CVE-2025-27608","markdown":"https://insights.sbomify.com/CVE-2025-27608/index.md","name":"CVE-2025-27608","record":{"aliases":["GHSA-252h-4j5q-88pc"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Arduino IDE","requires_auth":"none","summary":"Self-XSS in Arduino IDE allows attackers to execute arbitrary code via malicious input in the Board Manager URLs field.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Arduino IDE 2.x is an IDE based on the Theia IDE framework and built with Electron. A Self Cross-Site Scripting (XSS) vulnerability has been identified within the Arduino-IDE prior to version v2.3.5. The vulnerability occurs in the Additional Board Manager URLs field, which can be found in the Preferences -\u003e Settings section of the Arduino IDE interface. In the vulnerable versions, any values entered in this field are directly displayed to the user through a notification tooltip object, without a proper output encoding routine, due to the underlying ElectronJS engine interpretation. This vulnerability exposes the input parameter to Self-XSS attacks, which may lead to security risks depending on where the malicious payload is injected. This vulnerability is fixed in 2.3.5.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Self Cross-Site Scripting in Arduino IDE","id":"CVE-2025-27608","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"Icinga Web 2 Vulnerable to Reflected XSS","id":"CVE-2025-27609"},"packages":[],"prev":{"headline":"Python JSON Logger has a Potential RCE via missing `msgspec-python313-pre` dependency","id":"CVE-2025-27607"},"products":["arduino-ide"],"published":"2025-04-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-03","vendors":["arduino"]},"summary":"Self-XSS in Arduino IDE allows attackers to execute arbitrary code via malicious input in the Board Manager URLs field.","url":"https://insights.sbomify.com/CVE-2025-27608/"}