# CVE-2025-27608: Self Cross-Site Scripting in Arduino IDE

> Self-XSS in Arduino IDE allows attackers to execute arbitrary code via malicious input in the Board Manager URLs field.

- **Severity:** Low 1.0 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 2 Apr 2025
- **Updated:** 3 Apr 2025
- **Also known as:** GHSA-252h-4j5q-88pc

## What is CVE-2025-27608?

CVE-2025-27608 is a low-severity cross-site scripting vulnerability in arduino-ide, published on 2 Apr 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Arduino IDE 2.x is an IDE based on the Theia IDE framework and built with Electron. A Self Cross-Site Scripting (XSS) vulnerability has been identified within the Arduino-IDE prior to version v2.3.5. The vulnerability occurs in the Additional Board Manager URLs field, which can be found in the Preferences -> Settings section of the Arduino IDE interface. In the vulnerable versions, any values entered in this field are directly displayed to the user through a notification tooltip object, without a proper output encoding routine, due to the underlying ElectronJS engine interpretation. This vulnerability exposes the input parameter to Self-XSS attacks, which may lead to security risks depending on where the malicious payload is injected. This vulnerability is fixed in 2.3.5.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-27608?


## How do I fix CVE-2025-27608?

No fix has been published for CVE-2025-27608 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-27608 being exploited?

There is no known exploitation of CVE-2025-27608 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27608 and fix it if it is affected.

What it is: CVE-2025-27608 is a low-severity cross-site scripting vulnerability in arduino-ide, published on 2 Apr 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-27608 in the wild and no public exploit code.

Affected product: arduino-ide. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27608/ (Markdown: https://insights.sbomify.com/CVE-2025-27608/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27608
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27608
- OSV: https://osv.dev/vulnerability/CVE-2025-27608

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27608/
Summaries are generated and may contain mistakes; the official description above is the record.
