{"answers":{"affected":"2 open source packages ship an affected version, including libcontainer.","exploited":"There is no known exploitation of CVE-2025-27612 in the wild and no public exploit code.","fix":"Upgrade libcontainer to 0.5.3 or later.","what":"CVE-2025-27612 is a medium-severity vulnerability in youki-dev youki, published on 21 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-27612 and fix it if it is affected.\n\nWhat it is: CVE-2025-27612 is a medium-severity vulnerability in youki-dev youki, published on 21 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-27612 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libcontainer (crates.io): affected all versions; fixed in 0.5.3\n- libcontainer (crates.io): affected all versions; fixed in 0.5.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-27612/ (Markdown: https://insights.sbomify.com/CVE-2025-27612/index.md)","id":"CVE-2025-27612","markdown":"https://insights.sbomify.com/CVE-2025-27612/index.md","name":"CVE-2025-27612","record":{"aliases":["CLEANSTART-2026-ON51112","GHSA-5w4j-f78p-4wh9","MINI-3422-2gmx-66gj","MINI-5w5r-8r77-36v7","MINI-6r6r-fcjj-m682","MINI-9h95-vmmq-g7pg","MINI-c635-fg9j-rh8w","MINI-f2hx-5c2j-h9m2","MINI-fjmj-96j8-cjm3","MINI-frw6-2gcm-9h36","MINI-g7vx-49j5-2pjf","MINI-hvqp-54fr-w5x4","MINI-mfp8-p9wh-vp5v","MINI-q97c-8cpw-22x2","MINI-v2qf-j45h-9g9r","MINI-v4r8-8gj9-9m9m","MINI-vc9v-j9mx-63hg","MINI-wj45-fjfx-3392","MINI-wqmm-6849-pxqf"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Container runtime library","requires_auth":"none","summary":"Attackers using libcontainer's tenant builder can elevate container capabilities, potentially gaining unauthorized privileges within the container environment.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-276","name":"Incorrect Default Permissions"}],"description":"libcontainer is a library for container control. Prior to libcontainer 0.5.3, while creating a tenant container, the tenant builder accepts a list of capabilities to be added in the spec of tenant container. The logic here adds the given capabilities to all capabilities of main container if present in spec, otherwise simply set provided capabilities as capabilities of the tenant container. However, setting inherited caps in any case for tenant container can lead to elevation of capabilities, similar to CVE-2022-29162. This does not affect youki binary itself. This is only applicable if you are using libcontainer directly and using the tenant builder.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Libcontainer is affected by capabilities elevation","id":"CVE-2025-27612","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"privilege_escalation","year":"2025"},"n_packages":2,"n_references":4,"next":{"headline":"Gitk can create and truncate files in the user's home directory","id":"CVE-2025-27613"},"packages":[{"ecosystem":"crates.io","fixed":["0.5.3"],"introduced":["0"],"last_affected":[],"package":"libcontainer","purl":null,"source":"GHSA-5w4j-f78p-4wh9"},{"ecosystem":"crates.io","fixed":["0.5.3"],"introduced":["0"],"last_affected":[],"package":"libcontainer","purl":"pkg:cargo/libcontainer","source":"GHSA-5w4j-f78p-4wh9"}],"prev":{"headline":"base-x homograph attack allows Unicode lookalike characters to bypass validation.","id":"CVE-2025-27611"},"products":["youki"],"published":"2025-03-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-21","vendors":["youki-dev"]},"summary":"Attackers using libcontainer's tenant builder can elevate container capabilities, potentially gaining unauthorized privileges within the container environment.","url":"https://insights.sbomify.com/CVE-2025-27612/"}