CVE-2025-27616 Vela Server has Insufficient Webhook Payload Data Verification
Attackers can spoof webhook payloads to transfer repository ownership and exfiltrate CI secrets, affecting Vela server users.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-27616?
CVE-2025-27616 is a high-severity vulnerability in go-vela server, published on 10 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Vela is a Pipeline Automation (CI/CD) framework built on Linux container technology written in Golang. Prior to versions 0.25.3 and 0.26.3, by spoofing a webhook payload with a specific set of headers and body data, an attacker could transfer ownership of a repository and its repo level secrets to a separate repository. These secrets could be exfiltrated by follow up builds to the repository. Users with an enabled repository with access to repo level CI secrets in Vela are vulnerable to the exploit, and any user with access to the CI instance and the linked source control manager can perform the exploit. Versions 0.25.3 and 0.26.3 fix the issue. No known workarounds are available.
Which versions are affected by CVE-2025-27616?
5 open source packages ship an affected version, including github.com/go-vela/server.
| Package | Affected | Fixed in |
|---|---|---|
github.com/go-vela/server Go | All versions | 0.25.3, 0.26.3 |
github.com/go-vela/server Go | All versions | 0.25.3 |
github.com/go-vela/server Go | All versions | 0.25.3 |
github.com/go-vela/server Go | From 0.26.0 | 0.26.3 |
github.com/go-vela/server Go | From 0.26.0 | 0.26.3 |
How do I fix CVE-2025-27616?
Upgrade github.com/go-vela/server to a fixed version for your release line: 0.25.3 or 0.26.3.
Is CVE-2025-27616 being exploited?
There is no known exploitation of CVE-2025-27616 in the wild and no public exploit code.
Sources
Also known as GHSA-9m63-33q3-xq5x, GO-2025-3509.