# CVE-2025-27616: Vela Server has Insufficient Webhook Payload Data Verification

> Attackers can spoof webhook payloads to transfer repository ownership and exfiltrate CI secrets, affecting Vela server users.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2025
- **Updated:** 11 Mar 2025
- **Also known as:** GHSA-9m63-33q3-xq5x, GO-2025-3509

## What is CVE-2025-27616?

CVE-2025-27616 is a high-severity vulnerability in go-vela server, published on 10 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Vela is a Pipeline Automation (CI/CD) framework built on Linux container technology written in Golang. Prior to versions 0.25.3 and 0.26.3, by spoofing a webhook payload with a specific set of headers and body data, an attacker could transfer ownership of a repository and its repo level secrets to a separate repository. These secrets could be exfiltrated by follow up builds to the repository. Users with an enabled repository with access to repo level CI secrets in Vela are vulnerable to the exploit, and any user with access to the CI instance and the linked source control manager can perform the exploit. Versions 0.25.3 and 0.26.3 fix the issue. No known workarounds are available.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity), CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2025-27616?

5 open source packages ship an affected version, including github.com/go-vela/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/go-vela/server` | Go | All versions | 0.25.3, 0.26.3 |
| `github.com/go-vela/server` | Go | All versions | 0.25.3 |
| `github.com/go-vela/server` | Go | All versions | 0.25.3 |
| `github.com/go-vela/server` | Go | From 0.26.0 | 0.26.3 |
| `github.com/go-vela/server` | Go | From 0.26.0 | 0.26.3 |

## How do I fix CVE-2025-27616?

Upgrade github.com/go-vela/server to a fixed version for your release line: 0.25.3 or 0.26.3.

## Is CVE-2025-27616 being exploited?

There is no known exploitation of CVE-2025-27616 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27616 and fix it if it is affected.

What it is: CVE-2025-27616 is a high-severity vulnerability in go-vela server, published on 10 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27616 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/go-vela/server (Go): affected all versions; fixed in 0.25.3, 0.26.3
- github.com/go-vela/server (Go): affected all versions; fixed in 0.25.3
- github.com/go-vela/server (Go): affected all versions; fixed in 0.25.3
- github.com/go-vela/server (Go): affected from 0.26.0; fixed in 0.26.3
- github.com/go-vela/server (Go): affected from 0.26.0; fixed in 0.26.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27616/ (Markdown: https://insights.sbomify.com/CVE-2025-27616/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27616
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27616
- OSV: https://osv.dev/vulnerability/CVE-2025-27616

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27616/
Summaries are generated and may contain mistakes; the official description above is the record.
