CVE-2025-27624 Jenkins cross-site request forgery (CSRF) vulnerability

Medium 5.4 Published Updated

Attackers can trick users into toggling sidepanel widget visibility in Jenkins, causing minor UI disruption without significant security impact.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-27624?

CVE-2025-27624 is a medium-severity vulnerability in Jenkins Jenkins, published on 5 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A cross-site request forgery (CSRF) vulnerability in Jenkins 2.499 and earlier, LTS 2.492.1 and earlier allows attackers to have users toggle their collapsed/expanded status of sidepanel widgets (e.g., Build Queue and Build Executor Status widgets).

Weakness: CWE-352

Which versions are affected by CVE-2025-27624?

5 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.492.2
org.jenkins-ci.main:jenkins-core MavenAll versions2.492.2
org.jenkins-ci.main:jenkins-core MavenFrom 2.4932.500
org.jenkins-ci.main:jenkins-core MavenFrom 2.4932.500
jenkins BitnamiFrom 2.493.02.504.1

Products include Jenkins Jenkins.

How do I fix CVE-2025-27624?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.492.2 or 2.500.

Is CVE-2025-27624 being exploited?

There is no known exploitation of CVE-2025-27624 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as BIT-jenkins-2025-27624, GHSA-7g95-jmg9-h524, MINI-5x93-53fm-fh2q, MINI-7fx5-w6q9-wgh3.

Is CVE-2025-27624 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free