# CVE-2025-27625: Jenkins Open Redirect vulnerability

> Attackers can redirect users to malicious sites via backslash-prefixed URLs, facilitating phishing attacks against Jenkins users.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Mar 2025
- **Updated:** 6 Mar 2025
- **Also known as:** BIT-jenkins-2025-27625, GHSA-8hmv-92wm-39ch, MINI-4jfq-w553-q84p, MINI-8jj8-8229-338h

## What is CVE-2025-27625?

CVE-2025-27625 is a medium-severity vulnerability in Jenkins Jenkins, published on 5 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Jenkins 2.499 and earlier, LTS 2.492.1 and earlier, redirects starting with backslash (`\`) characters are considered safe, allowing attackers to perform phishing attacks by having users go to a Jenkins URL that will forward them to a different site, because browsers interpret these characters as part of scheme-relative redirects.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2025-27625?

5 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.492.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.492.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.493 | 2.500 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.493 | 2.500 |
| `jenkins` | Bitnami | From 2.493.0 | 2.504.1 |

Products: Jenkins Jenkins.

## How do I fix CVE-2025-27625?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.492.2 or 2.500.

## Is CVE-2025-27625 being exploited?

There is no known exploitation of CVE-2025-27625 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27625 and fix it if it is affected.

What it is: CVE-2025-27625 is a medium-severity vulnerability in Jenkins Jenkins, published on 5 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-27625 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.492.2
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.492.2
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.493; fixed in 2.500
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.493; fixed in 2.500
- jenkins (Bitnami): affected from 2.493.0; fixed in 2.504.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27625/ (Markdown: https://insights.sbomify.com/CVE-2025-27625/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27625
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27625
- OSV: https://osv.dev/vulnerability/CVE-2025-27625

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27625/
Summaries are generated and may contain mistakes; the official description above is the record.
