CVE-2025-27636 Apache Camel: Camel Message Header Injection via Improper Filtering
Attackers can inject malicious headers to alter application behavior, potentially executing unintended code or redirecting messages in Apache Camel applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-27636?
CVE-2025-27636 is a medium-severity code injection vulnerability in Apache Camel, published on 9 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Bypass/Injection vulnerability in Apache Camel components under particular conditions.
This issue affects Apache Camel: from 4.10.0 through <= 4.10.1, from 4.8.0 through <= 4.8.4, from 3.10.0 through <= 3.22.3.
Users are recommended to upgrade to version 4.10.2 for 4.10.x LTS, 4.8.5 for 4.8.x LTS and 3.22.4 for 3.x releases.
This vulnerability is present in Camel's default incoming header filter, that allows an attacker to include Camel specific
headers that for some Camel components can alter the behaviours such as the camel-bean component, to call another method
on the bean, than was coded in the application. In the camel-jms component, then a malicious header can be used to send
the message to another queue (on the same broker) than was coded in the application. This could also be seen by using the camel-exec component
The attacker would need to inject custom headers, such as HTTP protocols. So if you have Camel applications that are
directly connected to the internet via HTTP, then an attacker could include malicious HTTP headers in the HTTP requests
that are send to the Camel application.
All the known Camel HTTP component such as camel-servlet, camel-jetty, camel-undertow, camel-platform-http, and camel-netty-http would be vulnerable out of the box.
In these conditions an attacker could be able to forge a Camel header name and make the bean component invoking other methods in the same bean.
In terms of usage of the default header filter strategy the list of components using that is:
* camel-activemq * camel-activemq6 * camel-amqp * camel-aws2-sqs * camel-azure-servicebus * camel-cxf-rest * camel-cxf-soap * camel-http * camel-jetty * camel-jms * camel-kafka * camel-knative * camel-mail * camel-nats * camel-netty-http * camel-platform-http * camel-rest * camel-sjms * camel-spring-rabbitmq * camel-stomp * camel-tahu * camel-undertow * camel-xmpp
The vulnerability arises due to a bug in the default filtering mechanism that only blocks headers starting with "Camel", "camel", or "org.apache.camel.".
Mitigation: You can easily work around this in your Camel applications by removing the headers in your Camel routes. There are many ways of doing this, also globally or per route. This means you could use the removeHeaders EIP, to filter out anything like "cAmel, cAMEL" etc, or in general everything not starting with "Camel", "camel" or "org.apache.camel.".
Weakness: CWE-178
Which versions are affected by CVE-2025-27636?
6 open source packages ship an affected version, including org.apache.camel:camel-support. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.camel:camel-support Maven | From 3.10.0 | 3.22.4 |
org.apache.camel:camel-support Maven | From 3.10.0 | 3.22.4 |
org.apache.camel:camel-support Maven | From 4.0.0-M1 | 4.8.5 |
org.apache.camel:camel-support Maven | From 4.0.0-M1 | 4.8.5 |
org.apache.camel:camel-support Maven | From 4.9.0 | 4.10.2 |
org.apache.camel:camel-support Maven | From 4.9.0 | 4.10.2 |
Products include Apache Camel.
How do I fix CVE-2025-27636?
Upgrade org.apache.camel:camel-support to a fixed version for your release line: 3.22.4, 4.8.5 or 4.10.2.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2025-27636 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27636 exists.
Public exploit code: 5 proofs of concept on GitHub.
Other vulnerabilities in Apache Camel
- CVE-2026-33453 Apache camel-coap allows header injection that can lead to remote code execution
- CVE-2026-40453 Apache Camel has an incomplete fix for CVE-2025-27636
- CVE-2026-80351 Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod
- CVE-2026-80352 Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects
- CVE-2026-71300 Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection
Sources
Also known as GHSA-2c2h-2855-mf97.