CVE-2025-27696 Apache Superset: Incorrect authorization leading to resource ownership takeover

Medium 5.3 Published Updated

Authenticated users with read permissions can take ownership of dashboards, charts, or datasets due to incorrect authorization checks.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-27696?

CVE-2025-27696 is a medium-severity missing authorization vulnerability in Apache Superset, published on 13 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Incorrect Authorization vulnerability in Apache Superset allows ownership takeover of dashboards, charts or datasets by authenticated users with read permissions.

This issue affects Apache Superset: through 4.1.1.

Users are recommended to upgrade to version 4.1.2 or above, which fixes the issue.

Weakness: CWE-863

Which versions are affected by CVE-2025-27696?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.

PackageAffectedFixed in
apache-superset PyPIAll versions4.1.2
apache-superset PyPIAll versions4.1.2
apache-superset PyPIAll versions4.1.2
superset BitnamiAll versions4.1.2

Products include Apache Superset.

How do I fix CVE-2025-27696?

Upgrade apache-superset to 4.1.2 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-27696 being exploited?

There is no known exploitation of CVE-2025-27696 in the wild and no public exploit code.

All Apache Superset vulnerabilities

Sources

Also known as BIT-superset-2025-27696, GHSA-w6c7-j32f-rq8j, PYSEC-2026-1189.

Is CVE-2025-27696 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free